PDA

View Full Version : D3D Render Creation Error


DanFraser
06-02-02, 05:26 PM
Weird one this... I have a Gainward GeForce4 ti 4600 Golden Sample Ultra/750 XP VIVO Twinview DVI Out... This does support VIVO etc... Well, should. Thing is, I can hook up my TV fine, and run Windows XP quite happily without any hint of a problem.

But, then I come to games... SimCity 3000 UK Edition... Just sits there, no hangs, or crashes, no reports of errors (until I force it closed through task manager) nothing... My computer doesnt even notice it was trying to run it. Then Cossacks European Wars The Art Of War... a DirectX version error (I have 8.1 btw) appears saying I have version 7.0 and not 7.0a the minimum needed for the game... The I put in Star Trek Bridge Commander. And I get this error message:

D3D Render Creation Error
Error string from renderer was:
"Creation Failed: Desired fullscreen display mode not supported"

I click ok, and it says the program (ST:BC) encountered a problem.

DXDiag doesnt report anything suspicious... Apart from not running the Hardware 3D test... Heres the report. Sorry about the length, but I chopped out sound and directplay.

------------------
System Information
------------------
Time of this report: 6/2/2002, 23:30:02
Machine name: STARFLEET1
Operating System: Microsoft Windows XP Professional (5.1, Build 2600) (2600.xpclnt_qfe.010827-1803)
Language: English (Regional Setting: English)
System Manufacturer: ECS
System Model: K7S5A
BIOS: AMIINT - 1000
Processor: AMD Athlon(tm) XP 2000+, MMX, 3DNow, ~1613MHz
Memory: 384MB RAM
Page File: 154MB used, 1216MB available
Primary File System: n/a
DirectX Version: DirectX 8.1 (4.08.01.0810)
DX Setup Parameters: Not found
DxDiag Version: 5.01.2600.0000 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: The file nv4_disp.dll is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs. You may be able to get a signed driver from the manufacturer of the hardware device.
DirectDraw test results: All tests were successful.
Direct3D test results: Failure at step 5 (GetDeviceCaps): HRESULT = 0x8876086a (3D not available)
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No input devices detected.
No problems found.
Network Tab: No problems found.

---------------
Display Devices
---------------
Card name: NVIDIA GeForce4 Ti 4600
Manufacturer: NVIDIA
Chip type: GeForce4 Ti 4600
DAC type: Integrated RAMDAC
Device ID: Enum\PCI\VEN_10DE&DEV_0250&SUBSYS_152810B0&REV_A2
Display Memory: 128.0 MB
Current Mode: 1024 x 768 (16 bit) (60Hz)
Monitor: Default Monitor
Monitor Max Res:
Driver Name: nv4_disp.dll
Driver Version: 6.13.10.2890 (English)
DDI Version: 7
Driver Attributes: Final Retail
Driver Date/Size: 4/2/2002 12:06:00, 3529581 bytes
Driver Signed: No
WHQL Date Stamp: None
VDD:
Mini VDD: nv4_mini.sys
Mini VDD Date: 4/2/2002 12:06:00, 919629 bytes
Device Identifier: {D7B71E3E-4110-11CF-4A78-223500C2CB35}
Vendor ID: 0x10DE
Device ID: 0x0250
SubSys ID: 0x152810B0
Revision ID: 0x00A2
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: All tests were successful.
D3D7 Test Result: All tests were successful.
D3D8 Test Result: Failure at step 5 (GetDeviceCaps): HRESULT = 0x8876086a (3D not available)

See... Nothing out of the ordinary.

What is even stranger is that as soon as I switch back to my monitor, without a restart, these games run fine... Anyone got any ideas? This is driving me mental... Its not important, but its something that shouldnt be happening. Has XP got a problem? Has DirectX kicked the bucket? Has the GF4?

o770
06-02-02, 06:02 PM
are you using any driver tweaker program like rivatuner? if so check whether the directx texture compressions are not disabled to the directx8 applications. at least rivatuner will disable them when you run some of the built-in d3d presets.
however if the problem happens only when youre trying to run games using the tv-out connection, that shouldnt be the problem. i would also try out other driver version to your video card and re-installing directx perhaps. you have many games, they use to mess with directx installation very often..

DanFraser
06-03-02, 08:21 AM
I was using GeForce Tweak Utility, but no thats set to default, and uninstalled...

DirectX 8.1 was installed by XP, so I dont know too much about reinstalling it.

Games didnt try installing DirectX 7/7.0a/8/8.0a as needed as I told them to get lost when they tried!

Is DirectX installable from the XP CD?

o770
06-03-02, 02:21 PM
i dont think so
did you ever get that working at all?

im not sure about gainward and that card - msi has major issues with the tv-out in the geforce 3 ti200 cards and i noticed there are some similar issues in the geforce 4 ti4400. so you can try emailing gainward about that.
ppl using the msi version 8850 got the tv-out problem fixed by flashing the video card bios with a newer release.. is there any updated bios to yours?

DanFraser
06-03-02, 02:30 PM
Fixed it... reinstalled the games... Well, it worked for two of them, dunno about Cossacks, yet...

o770
06-03-02, 02:56 PM
see, the directx diagnose has nothing to do with the games. if you run it now and it not reports any problem anymore then the games must be messed with the directx installation in the past. run it anyway. i dont beleive the games can fix that.