Results 1 to 5 of 5
  1. #1
    Member buckbadly's Avatar
    Join Date
    Feb 2002
    Location
    ohio

    Another freakin BF2 black screen at startup thread

    I have read through the various posts on people having problems with starting the BF2 demo...I used all the suggestions except changing to the drivers that come with the demo...I'm using 71.89's right now and like using them from a stability standpoint...anyone using the bundled drivers? I've tried everything and can't get it to start...any more suggestions? I want to play this and see how it looks on my system
    Gigabyte GA-790XTA-UD4
    Rosewill RP600V2-S-SL 600W
    AMD Phenom II X4 955 Black
    Stock heat sink for now
    G.SKILL Ripjaws Series 8GB (2 x 4GB)
    Dual WD SATA Raptors 10K
    1 WD SATA storage 500 Gig
    EVGA 9400GT
    Samsung 940BW
    LITE-ON DVD+/-RW SOHW-1633S 16X Dual Layer

    ----------------------------------------------------

  2. #2
    Member Goateh's Avatar
    Join Date
    Apr 2003
    Location
    NewZealand
    You have tried the bundled drivers?

    Asus PZ68-M Pro :: Intel Core i5 2500k :: Stock Cooling :: MSI GTX560:: 2 x 4GB Kingston Hyper-X 1600Mhz

    "Some day you too will know my pain and smile it's black tooth grin.."
    -Dave Mustaine, Megadeth


  3. #3
    Member buckbadly's Avatar
    Join Date
    Feb 2002
    Location
    ohio
    No I haven't...I haven't seen them on Nvidia's site so I didn't know how they were from a stability standpoint. I'm running the 71.89's right now and like them....but if the bundled drivers will allow me to play I'll give em a shot I guess
    Gigabyte GA-790XTA-UD4
    Rosewill RP600V2-S-SL 600W
    AMD Phenom II X4 955 Black
    Stock heat sink for now
    G.SKILL Ripjaws Series 8GB (2 x 4GB)
    Dual WD SATA Raptors 10K
    1 WD SATA storage 500 Gig
    EVGA 9400GT
    Samsung 940BW
    LITE-ON DVD+/-RW SOHW-1633S 16X Dual Layer

    ----------------------------------------------------

  4. #4
    Member ninthebin's Avatar
    Join Date
    Mar 2002
    Location
    Liverpool, UK
    afaik this is a refresh rate bug that has been in this series of games since bf1942 - never fixed in any of the patches / new game releases.

    apparently the game refuses to start in anything but 800x600 @ 60Hz - if for any reasons your renderer can not do that then it wont start (IE refresh rate above 60Hz locked at say 85Hz may cause it if the driver is unable to change back to 60Hz) - in BF1942 it was simply the case of either going to the video.con and changing render.allowallrefreshrates to 1 - however that didnt seem to work for me in bf2...so I tried setting my refresh rate to 60Hz, didnt work either.

    Eventually I landed on finding that bf2 stores other video.cons for you in your my documents folder and simply changing the resolution from 800 x 600 @ 0 to @ 75 (in my case) it worked - you could try this also, but I dont know why this requires different methods for the same bug as the older games :x

    other video.cons exist in your bf2/mods/settings folder and its recommended you delete the profiles folder in bf2

    hope any of this helps

  5. #5
    Member buckbadly's Avatar
    Join Date
    Feb 2002
    Location
    ohio
    ninthebin...thanx for takin the time to post...I tried that one as well...I got it to load by going ahead and using the drivers they bundled with the demo...guess I'll see how they behave and get along with the rest of my games in the next few days.
    Gigabyte GA-790XTA-UD4
    Rosewill RP600V2-S-SL 600W
    AMD Phenom II X4 955 Black
    Stock heat sink for now
    G.SKILL Ripjaws Series 8GB (2 x 4GB)
    Dual WD SATA Raptors 10K
    1 WD SATA storage 500 Gig
    EVGA 9400GT
    Samsung 940BW
    LITE-ON DVD+/-RW SOHW-1633S 16X Dual Layer

    ----------------------------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •