Hi guys, I am having a lot of problems with my serial ports. I recently tried to install a Lacrosse Weather Station that connects to the computer via serial port.

The software opens up and then greys out, saying that the serial port I want to use is already in use by another application or program or whatever. All four com ports show the same issue.

I have uninstalled and reinstalled the software, to no avail. I have turned off such applications like my UPS which use the serial port, to no avail.

I had my UPS connected to the rear of my computer at first, I unplugged it, turned it off in the config sys and then rebooted, the weather station worked fine. Then after the next reboot everything stopped working again. I tried to disconnect the base station from the serial port upon rebooting, it didn't work, I tried uninstalling and reinstalling, it didn't work. I tried using different software, it didn't work. I made sure the UPS was still disconnected, it is... So I am up against a wall here, I really want to use the serial port connection for my weather station, but no matter what I do, I cannot figure out what is going on.

How can I determine what serial ports are in use or change them? Someone recommended procmon.exe to monitor the processes, but I have no idea what I am doing with the program, when I do a search for serial, so much stuff comes up I have no idea what I am looking at. There must be some conflicts in my system, but what bothers me is that it was working and now it is not, and I worry in the future I will continually have isses after rebooting.

Can someone help me? Thanks