Results 1 to 11 of 11
  1. #1
    Registered
    Join Date
    Dec 2007
    Posts
    15

    Windows Photo Gallery says all my pictures are corrupt!

    Whenever I try to open a picture in Windows Photo Gallery, be it .jpg, .png, or .gif, it always opens windows photo gallery, but instead of the picture, it has the error "Photo Gallery can't open this picture or video. The file appears to be damaged or corrupted." However, I can see the thumbnails in windows explorer, and when I open the picture up in Nero picture viewer, Office picture viewer, etc, I can see the picture fine.

    It doesn't matter where the picture is, photo gallery just won't open it.

    I would use Office Picture Viewer or Nero Picture Viewer, but I don't like either of them.

    Any help would be greatly appreciated, this is driving me nuts!

    Here's a link to a screenshot of the problem (didn't want to [img] tag it because it's 1280x1024, or close to it):
    Code:
    http://img.photobucket.com/albums/v72/tamriilin_omani/cantopen.jpg

  2. #2

  3. #3
    Registered
    Join Date
    Dec 2007
    Posts
    15
    Will try it now.

    Thanks for the suggestion!

    The reason I hadn't already done this was because I didn't know you could even download it from anywhere...

    EDIT: Nope, still didn't fix anything.
    Last edited by tamriilin; 03-12-09 at 11:05 AM.

  4. #4
    Super Moderator
    First Responders
    -->
    redduc900's Avatar
    Join Date
    Dec 2000
    Location
    Portland, OR
    Posts
    16,749
    Where are the images located that you're trying to open?

  5. #5
    Member Trombe's Avatar
    Join Date
    Mar 2005
    Location
    Austin, Texas
    Posts
    1,084
    Can you open them in another program and resave them?

  6. #6
    Registered
    Join Date
    Dec 2007
    Posts
    15
    Quote Originally Posted by redduc900 View Post
    Where are the images located that you're trying to open?
    My first post:
    Quote Originally Posted by tamriilin
    It doesn't matter where the picture is, photo gallery just won't open it.
    I.E., I've tried to open photos from every location imaginable on my hard drives, but Vista's photo gallery will not open them.


    Quote Originally Posted by Trombe
    Can you open them in another program and resave them?
    Yes, I could, but that would take weeks as I have hundreds of megabytes worth of pictures.

    Also, I don't see how this could be the problem, as this even happens with pictures I've -just- saved.
    Last edited by tamriilin; 03-12-09 at 04:14 PM.

  7. #7
    oakstave's Avatar
    Join Date
    Mar 2007
    Location
    Oregon
    Posts
    1,343
    This is a longshot, but here goes... Many picture viewer programs place a small file in the folder with the pics. This file provides thumbnail information and information on how you have set these pics to be viewed...

    I've never had this problem with P.G. with Vista, but is it possible there is a corrupt tag in the folder that holds the pictures? If so, I would assume this is a hidden file, and you would have to set the preferences to show hidden files.

    Once you find this tag file... (I don't know what it's called)... you could delete it, and and Photo Gallery would recreate it the first time you opened the folder again.

    I don't know... reachin' here, but it's a thought.
    "If you consider the entertainment value of armageddon, the future doesn't seem all that dim."

  8. #8
    Registered
    Join Date
    Dec 2007
    Posts
    15
    Quote Originally Posted by oakstave View Post
    This is a longshot, but here goes... Many picture viewer programs place a small file in the folder with the pics. This file provides thumbnail information and information on how you have set these pics to be viewed...

    I've never had this problem with P.G. with Vista, but is it possible there is a corrupt tag in the folder that holds the pictures? If so, I would assume this is a hidden file, and you would have to set the preferences to show hidden files.

    Once you find this tag file... (I don't know what it's called)... you could delete it, and and Photo Gallery would recreate it the first time you opened the folder again.

    I don't know... reachin' here, but it's a thought.
    You're referring to thumbs.dll, I think - that's only for certain items that can't be opened with windows photo gallery (i.e. music folder album covers), I think.

    In short: I don't have thumbs.dll in -any- of my folders.

    Thanks for the reply though.

  9. #9
    Member Rich'[ard]'s Avatar
    Join Date
    Apr 2008
    Location
    Melb, AUS
    Posts
    2,734
    are the files in different languages? i can never open my pictures with Chinese titles cos it gives some error looking like

    "??? cannot be opened"

    do you have photoshop or anything that you can open the pics with? or any other program
    яιн.
    Processor 3570K @ 4.5GHz 1.2v
    Heatsink Noctua NH-D14
    Motherboard Gigabyte G1 Sniper-M3
    Memory 8GB Vengeance C9
    Storage Samsung 830 120GB + Seagate Barracuda 2TB
    Graphics Powercolor 7950 PCS+
    Power Corsair HX650
    Case Corsair 300R
    Windows w7 64bit
    Goodies Logitech z5400 5.1............G15|G3
    HP Folio 13 Ultrabook

  10. #10
    Registered
    Join Date
    Dec 2007
    Posts
    15
    Quote Originally Posted by Rich'[ard] View Post
    are the files in different languages? i can never open my pictures with Chinese titles cos it gives some error looking like

    "??? cannot be opened"

    do you have photoshop or anything that you can open the pics with? or any other program
    Someone already asked this...

    Yes, I do, but they're all far inferior to windows photo gallery.

    If you can recommend me a good picture viewer that supports .gif files and lets me browse pictures using the arrow keys, please do!

  11. #11
    orion456's Avatar
    Join Date
    May 2004
    Location
    Canada
    Posts
    3,173
    Did you run chkdsk. It's possible a file or folder is corrupt and could just need fixing.
    -- W3570 @ 3.8 P6TD on Swiftech H20-220
    -- QX9650 P5K-E on Swiftech H20-220 water, ATI 3870, G.Skill PC 8500.



    The only thing for sure, is that nothing is for sure!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •