Results 1 to 2 of 2
  1. #1

    ECS 649-M2 LGA775 LAN driver issue

    I just had to do a reformat on a pre-built computer for someone. Of course, like everyone, they had lost the disc with all the drivers and utilities.

    I thought "no problem, I'll just download them from the manufacturer's site"

    So anyway, the problem I'm having is getting the ethernet port working.

    Here is ECS's page with the motherboard drivers: http://www.ecs.com.tw/ECSWebSite_200...nuID=1&LanID=0

    ECS's site say that the ethernet port requires the Realtek RTL81xxx driver, but after installing this, still no internet connection..

    After some reading, I found that this was not the correct driver, and that the port is actually controlled by the SIS 965L southbridge. So I downloaded the driver from SIS's site, but still no luck.

    The ethernet port is enabled in device manager and in the BIOS.


    I am really stumped here, does anyone have any ideas on what I could do?
    Phenom 1055 + TU120E lapped -MSI 770-C45 - 2x2GB OCZ DDR3 1066 - Sapphire HD 4870 - Samsung Spinpoint 500GB 7200RPM 16MB cache HDD - Tagan TG600-BZ Piperock - Gigabyte 3D Aurora (Currently open test bed) - Windows Vista Home Premium 64bit.

  2. #2
    Member
    gregmacknass's Avatar
    Join Date
    Feb 2010
    Location
    Indiana
    Heatware Profile
    Try the second 1 on the list.
    http://driverscollection.com/?H=649-...8Elitegroup%29
    -Greg
    Gigabyte GA-Z77X-UD5H
    I7 3770K 4.8 1.42v on water D-TEK Fusion V2
    4x2GB OCZ
    EVGA GTX 770 with EK FC770 and backplate
    Antec EA750
    55" Toshiba 55WX800U LED 1080P monitor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •