Results 1 to 10 of 10
  1. #1
    Registered Prestito's Avatar
    Join Date
    Jan 2011

    Problem with Saitek Cyborg V7 Keyboard

    Hey, i really need urgent help.

    I just bought i Saitek Cyborg V7 Keyboard.

    The problem is that i cant install drivers for it to make it work. I have tried everything and nothing seems to work.

    The lights work on it but the keys dont work nor does the driver work (after accepting the agreements it tells me to plug in a device that i want to update, but it doesnt find my keyboard)

    I currently have Windows 7 Ultimate 64 bit.

    Someone please help

  2. #2
    Super Moderator
    First Responders
    -->
    redduc900's Avatar
    10 Year Badge
    Join Date
    Dec 2000
    Location
    Portland, OR
    You downloaded the "Saitek_Cyborg_Keyboard_SD6_64_Drivers_pfw.exe " package from Mad Catz?

  3. #3
    Registered Prestito's Avatar
    Join Date
    Jan 2011
    yes ive downloaded the drivers, but when it doesnt pick up the keyboard. When i log into windows, the windows updates try to update the drivers for the keyboard but it just fails everytime. also the keyboard doesnt work on my older 32bit pc.

  4. #4
    Super Moderator
    First Responders
    -->
    redduc900's Avatar
    10 Year Badge
    Join Date
    Dec 2000
    Location
    Portland, OR
    From the Cyborg support FAQ...
    With the keyboard plugged in (and not responding) go to Control Panel > System > Device Manager.

    You should see two entries for the keyboard accompanied by exclamation marks in the Human Interface section.

    Right click one of the entries and select Update Driver, then select browse my computer for driver software.

    Select 'Let me pick from a list...' From the list you are presented with, select either USB-Human Interface Device or HID-compliant device and click next. Repeat for the other entry and the computer should now see your keyboard as a basic USB keyboard. This will allow you to reinstall the Saitek driver for the board.

  5. #5
    Registered Prestito's Avatar
    Join Date
    Jan 2011
    It worked... THANKS YOU SO MUCH.!!!!!!!!!!111!!!1!! you dont believe how greatful i am, you are a life saver!

  6. #6
    New Member
    Join Date
    Dec 2012
    hi im not sure if you will get this message but i just brought a cyborg v.7 keyboard with my hopes high i plugged it in and it said driver device software installing at the bottom right. i left it for a bit and there was a message saying driver device was not sucessfuly installed. i though i might need to software from the website so i downloaded it and then it said agree and i did all of that. it came up with plug in the usb, i did but it wouldent let me press next. i also plugged it in to my laptop and it worked for some reason. pleasee can somone help me it was a birthday present aswell so please

  7. #7
    New Member
    Join Date
    Oct 2010
    Quote Originally Posted by redduc900 View Post
    From the Cyborg support FAQ...
    life saver.. was starting to get grumpy on xmas!

  8. #8
    New Member
    Join Date
    Dec 2012
    Got this keyboard from the wife for christmas and its driving me nuts..... installed fine on a clean windows 7 install, all lights and keys are fine apart from the profile keys at the side.... i programmed 2 of them last night but took 5 or 10 mins to start working, and yes i changed keyboard to red active mode... but this morning when i loaded the profiles they just wont work, even though its the same ones from last night and its in red/active mode... even pressed the side buttons on the top of the touch sensative parts but still does nothing when i press the buttons @ the side... but in the profile it shown me pressing the button as it flashed purple in the profile keyboard..... it even works when i do the test it shows what is ment to happen... but even in notepad nothing happens... its driving me nuts any help guys?

  9. #9

  10. #10
    New Member
    Join Date
    Dec 2013
    Hi. i have tried this three times now after changing my motherboard and it still does not work.. when i'm in the programmer it reacts to the macro keys and the lights are working but i can not write or play with the keyboard. any ideas how to fix it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •