Results 1 to 7 of 7
  1. #1
    New Member
    Join Date
    Jul 2010

    Asus P8 P67 Pro & i5 2500 - RAM issues

    Hi Guys

    Haven't posted here in a while but love the experience and help I got last time so I am back.

    I recently (yesterday) upgraded my Core2Quad setup and put in an Asus P8 P67 Pro mobo with an i5 2500 3.3gHz CPU. With this I bought 8gb g.skill ddr3-1600 RAM.

    Little did I know, and you only see this after reading the manual, that due to the intel cpu design, 2200 ram runs at 2000, 2000 at 1800 and 1800 at 1600. So I was pretty peeved to see that the mobo reports that my maximum bandwidth from my ram is 1333.

    So, out of the box, the mobo overclocks the i5 from 3.3gHz to 4.1gHz without a problem but only brings the RAM up to 1334mHz. I tried the default XMP profile that comes with the mobo but this just caused the board to go into its configuration cycle to try and find a safe boot state.

    Does any1 have any ideas or experience with this issue? I don't see why I paid extra for 1600 RAM if it is going to run at 1333.

    Further info:
    1) No I have not updated my bios. It is the rev3 that it comes out with.
    2) No I have not manually set any timings or anything.....because I am not sure about them.
    3) What I did read in the mobo user docs is that in order to get the vendor specified speed out of the ram I need to over clock.
    4) RAM = g.skill f3-12800cl7d-4gbeco ...... 7-8-7-24

    Any help/suggestions would be highly appareciated.

    Thanx in advance.

  2. #2
    Super Moderator
    First Responders
    redduc900's Avatar
    10 Year Badge
    Join Date
    Dec 2000
    Portland, OR
    At a default BCLK of 100 just manually select DDR3-1600MHz from the available Memory Frequency options. Also manually adjust the four primary RAM timings to 7-8-7-24 (leave all the sub-timings on Auto), and the DRAM voltage to 1.35V. You might also want to check and make sure you're running the latest BIOS revision, which I think is 1401, or you may run into POSTing issues w/ the RAM running at the higher frequency (it's an issue w/ that particular board).

  3. #3
    New Member
    Join Date
    Jul 2010
    Ahh thanx man. I will try that when I get home and see what happens. Funnily enough I think I did select the 1600 option manually.....but it was late so I am not sure where that went

    Anyway...thanx for the reply. Will post again in a few hours.

  4. #4
    New Member
    Join Date
    Jul 2010
    Okies so I did everything you suggested and it doesn't work. I am on ACPI BIOS revision 1502.
    Gonna boot normally now and load the ASUS utility software and see if there are any updates available.

  5. #5
    New Member
    Join Date
    Jul 2010

    SO checked manually and using the ASUS Updater and I am on the latest BIOS. I also tried using the ASUS Suite tuning software and still can't get the machine to boot on anything but 1333.

    I am starting to think that this was a bum purchase.

  6. #6

  7. #7
    Check THIS thread. I used the info here and my rig is OC'd to 5GHz when video encoding and idles at 1.6GHZ at 1.1vcore when doing typical "stuff". You may not see 5GHz (that is CPU dependent) but you will have a successful OC.
    ASUS P8P67-Pro B3: i2600K; GSkill Ripjaws DDR3-1600 (2x4GB); Apogee GTX; Thermochill PA120.3; Swiftech D655; XFX-5870HD; WD 500GB Sata lll Raid-0; LG Blu-ray burner; Silverstone 750W modular; Windows 7 64Bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts