Results 1 to 4 of 4
  1. #1

    Razer Naga issue

    So, I have had this mouse about one year...and the middle mouse button is starting to experience occasional null-input. i can scroll no problem, but the button doesn't like to work every now and again. Is this an issue that can be fixed via drivers update? Or has the quality of mice gone downhill from 5 years ago....I have a Logitech MX-518 that still fully works from 5-7 years ago. I need the naga for the extra buttons though, it SERIOUSLY helps a lot.

    Thanks for any advice.
    CPU:------------Intel Core I7 6700k@4.4 GHz
    Heatsink:------------Cryorig H5A White
    Motherboard:-Asrock Z170 - Extreme 6
    Memory:-------2x4gb Corsair DDR4 3000 MHZ 15-17-17-35
    Power Supply:Kingwin Lazer Gold series 850w
    Video Card:---EVGA GTX 770 2GB
    Case:-----------Corsair Air 540 Silver/black edition
    HDD:------------TOSHIBA PH3300U-1I72/Western Digital Caviar Black 1tb
    SSD:------------Samsung 840 EVO 120GB

  2. #2
    Benching Team Leader
    Buckeye Moderator
    Janus67's Avatar
    10 Year Badge
    Join Date
    May 2005
    Location
    Columbus
    Author Profile Benching Profile Folding Profile Heatware Profile
    If the mouse is failing I would contact their support. At least in my experience with Logitech they have been very quick to assist with these issues and sent a new unit almost immediately (the main reason why I stick with Logitech to this day)
    Haswell Benching and Gaming: ASRock Z87 OC Formula : Intel i7 4770k w/ Phanteks PH-TC14 : 16GB 4x4GB G.Skill TridentX DDR3-2666 : 2x R9 290X
    Other Components: Samsung 840 Evo 500GB SSD : 2TB Hitachi 7200rpm : Seasonic Platinum 1000W : 3x1440p: Asus MG279q, Auria EQ276W, Crossover P27Q


    Folding User Stats

  3. #3
    Quote Originally Posted by Janus67 View Post
    If the mouse is failing I would contact their support. At least in my experience with Logitech they have been very quick to assist with these issues and sent a new unit almost immediately (the main reason why I stick with Logitech to this day)
    its the Razer that is failing :/ the logitech one still works 100%.
    CPU:------------Intel Core I7 6700k@4.4 GHz
    Heatsink:------------Cryorig H5A White
    Motherboard:-Asrock Z170 - Extreme 6
    Memory:-------2x4gb Corsair DDR4 3000 MHZ 15-17-17-35
    Power Supply:Kingwin Lazer Gold series 850w
    Video Card:---EVGA GTX 770 2GB
    Case:-----------Corsair Air 540 Silver/black edition
    HDD:------------TOSHIBA PH3300U-1I72/Western Digital Caviar Black 1tb
    SSD:------------Samsung 840 EVO 120GB

  4. #4
    Benching Team Leader
    Buckeye Moderator
    Janus67's Avatar
    10 Year Badge
    Join Date
    May 2005
    Location
    Columbus
    Author Profile Benching Profile Folding Profile Heatware Profile
    I know, but I would still contact their support and let them know of the issue. They may or may not have as good of warranty support ad Logitech but it is worth a shot.

    I guess you could always plug it into a different computer and see if the symptoms are still there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •