Results 1 to 2 of 2
  1. #1
    Registered
    Join Date
    Aug 2008

    SOLVED: Asrock Z77 Pro3 and Video Card Incompatibility Issues "victim"

    Just finished wiring the new build, ground up, and got me five beeps - video card. I'm running a PNY GTX 560. I've read the few reviews on Egg that complain about the board not recognizing cards, which seem to be Nvidia, and even one that was specifically PNY. Well, I took the chance....



    It boots with my old EVGA 7300GT. Soooo, have others had this issue? Should I contact Asrock and get a different model or swap the card? The build is basically a workstation w/o the workstation specific card; I do a lot of Photoshop, CAD, 3ds max, so I like the GTX for the cuda cores. Any advice would be fantastic.

    Thanks peeps.

    Edit: NVM, Bios update FTW......been swinging for the fences quite a bit tonight and FAILING!! GAH!
    Last edited by Isop; 07-13-12 at 02:49 AM.

  2. #2
    Premium Member #18 txus.palacios's Avatar
    Join Date
    Dec 2011
    Location
    Cádiz (Spain)
    Benching Profile Folding Profile
    Yes, BIOS update.

    Same happened with my 470s and thought the board was bricked.

    Reflashed the BIOS with a veeeeeeeeery old ATi something something and it worked.
    Maximus V Gene | i5-2500k @ 4.5GHz (ekHF) | 16GiB | GTX470 SLI @ 800MHz (ekFC) | m4 128GB | Arch + Win8
    [ more info... ]


    The only sound I want to hear out of my computer (unless I'm gaming or watching a movie) is the hum of my 6000 rpm fan pushing air through my heatsink. - Seebs
    If I turn up dead, somebody make sure they put "should have just benched in the cold" on my tombstone, along with my most recent superpi32m score. - I.M.O.G.
    I didn't go water-cooling for an air-cooling Vcore!! - bluezero5
    I'll rm -rf /yourface/* - thideras

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •