Notices

Overclockers Forums > Software > Games
Games Tips and general discussion
Forum Jump

Games stutter or freeze for a moment when in game sounds loaded.

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 05-05-12, 10:51 AM Thread Starter   #1
GilleyTheSilly
New Member



Join Date: May 2012

 
Games stutter or freeze for a moment when in game sounds loaded.


Windows 7 Home Premium x64
Intel Core i7 2630QM @ 2.00GHz
AMD Radeon HD 6770M
6GB DDR3

Under system information and device manager these are the two listed...

IDT High Definition Audio CODEC
Intel(R) Display Audio



For example, in Minecraft, Planetside 1, and Blacklight. When a gun is shot, door opening, player falling, etc the game may stutter quickly or freeze for a second or three. I disabled both sound devices in device manager and when a sound would happen the game runs smoothly. Though there are still what seems like random quick stutters every 10 to 20 seconds or so. As far as my knowledge goes all of the drivers are up to date but it is possible that something may not be.

http://imgur.com/a/YxKPG

Images from minecraft diagnostic view. These types of events also occur in planetside as well. Note this sound problem never occured when playing Skyrim.

This also occured during the Diablo 3 beta, the spikes/lag made the game completely unplayable. Didn't have enough time to attempt some kind of minor diagnosis because the beta ended.
GilleyTheSilly is offline   QUOTE Thanks
Old 05-05-12, 12:33 PM Thread Starter   #2
GilleyTheSilly
New Member



Join Date: May 2012

 
Also, tried Battlefield 2. In the main menu where you can select servers or edit settings, the game freezes for a split second roughly every second. But the interesting part which may actually help, is that if I change the resolution of the game, for about 10-20 seconds the game runs perfectly. Then the issues start again.

In planetside, If i change the audio driver, the game will also momentarily run perfectly.
GilleyTheSilly is offline   QUOTE Thanks
Old 05-06-12, 01:34 PM   #3
Shadowmonk

 
Shadowmonk's Avatar 

Join Date: Mar 2008

 
Control Panel>Sound>Audio Device>Right Click>Properties> Uncheck "Allow applications to take specific control of this device.>ENJOY!
Shadowmonk is offline   QUOTE Thanks
Old 05-06-12, 06:14 PM Thread Starter   #4
GilleyTheSilly
New Member



Join Date: May 2012

 
I tried that and disabling all enhancements. I don't notice any difference if there is one.
GilleyTheSilly is offline   QUOTE Thanks
Old 05-08-12, 11:33 AM Thread Starter   #5
GilleyTheSilly
New Member



Join Date: May 2012

 
And Here is a curious event... when running frap recording at 60fps, during the recording time the game runs perfectly lagless, stutterless, and absolutely smooth.
GilleyTheSilly is offline   QUOTE Thanks
Old 05-14-12, 12:02 PM Thread Starter   #6
GilleyTheSilly
New Member



Join Date: May 2012

 
Update: Tried a few different things, not much mind you but here is an update. Still unsolved.

Windows 7 Home Premium x64
Intel Core i7 2630QM @ 2.00GHz
AMD Radeon HD 6770M
6GB DDR3

Under device manager this is listed for sound...

High Definition Audio Device

For example, in Minecraft SP, Planetside 1 MP, and Portal SP. When a gun is shot, door opening, player falling and hitting ground, NPC talking, etc the game may stutter

quickly or freeze for a second or three. I disabled both sound devices in device manager and when a sound would happen the game runs smoothly. Though there are still

what seems like random quick stutters every 10 to 20 seconds or so. As far as my knowledge goes all of the drivers are up to date but it is possible that something may

not be.

http://imgur.com/a/YxKPG

Images from minecraft diagnostic view. These types of events also occur in planetside and portal. This also occured during the Diablo 3 beta, the spikes/lag made the

game completely unplayable. Didn't have enough time to attempt some kind of minor diagnosis because the beta ended.
Exported Data from System Information


System Info:

http://pastebin.com/rwv5g0Cn
http://pastebin.com/cgG8Jk58



Tried:
Disabling All Sound Enhancements in Control Panel-->Sound
Disabling allowing exclusive control of device in Control Panel-->Sound
Tried enabling verticle refresh
Edit: Tried reformatting

Last edited by GilleyTheSilly; 05-14-12 at 12:06 PM. Reason: Add an attempted solution
GilleyTheSilly is offline   QUOTE Thanks
Old 05-14-12, 12:48 PM   #7
madhatter256
Special Member ★

 
madhatter256's Avatar 

Join Date: Jul 2008
Location: CFL

 
Shot in the dark but I've seen it work when HDMI was new and coming out on videocards.


Does your AMD GPU have HDMI out? Do you use it? If you do not use it, uninstall the HDMI Audio drivers from AMD that links the IDT sound card to the GPU to carry the audio out of the HDMI port.

__________________
Folding User Stats
Heatware
madhatter256 is offline Folding Profile Heatware Profile   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Software > Games
Games Tips and general discussion
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 01:44 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?