Notices

Overclockers Forums > Hardware > Motherboards > Intel Motherboards
Intel Motherboards
Forum Jump

Is HPT BIOS 2.0.1024 = 2.34??

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 11-02-02, 06:13 AM Thread Starter   #1
LarryJoe
Member



Join Date: Feb 2002

 
Is HPT BIOS 2.0.1024 = 2.34??


I installed the official BF BIOS and am confused after reading a few threads here from the mod squad that edited it and state hpt 2.34.

So I flashed successfully, but first I upgraded the XP drivers to 2.32. Should I be running 2.34 drivers in XP?
LarryJoe is offline   QUOTE Thanks
Overclockers Approved
Which motherboard should you buy? Get the final word here. Check out the latest Overclockers reviews:
ASRock Z77 OC Formula Motherboard Review

ASRock teamed up with overclocker Nick Shih to make a high-end overclocking-based, yet functional for all users, motherboard named the Z77 OC Formula. It appears they have achieved it. Read More.

Get it at NewEgg for $239.99
ASUS Maximus V Formula Motherboard

The Maximus V Formula is part of the ROG (Republic of Gamers) series of motherboards, which in itself brings a high level of expectation. It's a no brainer, Overclockers Approved! Read more.

Get it at NewEgg for $279.99
Old 11-03-02, 03:13 AM   #2
Annamaria
Registered



Join Date: Aug 2002

 
Re: Is HPT BIOS 2.0.1024 = 2.34??


Quote:
Originally posted by LarryJoe
I installed the official BF BIOS and am confused after reading a few threads here from the mod squad that edited it and state hpt 2.34.

So I flashed successfully, but first I upgraded the XP drivers to 2.32. Should I be running 2.34 drivers in XP?

Installs first the driver for Highpoint v2.34 and subsequently flashing the new bios.
Annamaria is offline   QUOTE Thanks
Old 11-03-02, 04:38 AM Thread Starter   #3
LarryJoe
Member



Join Date: Feb 2002

 
Annamaria - could you be a little more clear? I already installed the BF BIOS. Does the BF BIOS contain the hpt 2.34 BIOS. If so, do you think I should now upgrade XP to 2.34?
LarryJoe is offline   QUOTE Thanks
Old 11-04-02, 09:18 PM   #4
Eggroll
Registered



Join Date: Apr 2002

 
LarryJoe,

As far as the official Abit BF BIOS, it shows on the Abit download site an HPT BIOS version of 2.0.1024 (as listed in your message subject) which doesn't coincide with anything on the HPT website (http://www.highpoint-tech.com/370drivers_down.htm). The BIOSes on the HPT site jump from 2.0.0919 to 2.3. It wouldn't appear that the 2.0.1024 does equal 2.34 as I downloaded HPT BIOS/Driver files 2.3, 2.31, 2.32 and 2.34 and their readme's all give BIOS versions identical to their driver numbers -- that is: 2.3, 2.31, 2.32 and 2.34.

A post by arman68 (http://forum.oc-forums.com/vb/showth...hreadid=129687) states that the modified BF+ BIOS has the 2.32 HPT BIOS. Another post suggested that you would be able to use either the 2.32 or the 2.34 drivers with this 2.32 BIOS saying that newer drivers should be backwards compatible with an earlier BIOS. It seems to suggest that the opposite (newer BIOS, older drivers,) however, would not work.

If all of this information is correct (and that's "if,") it would seem your choices are as follows: (1) Stick with the official Abit BF BIOS and use any of the drivers from the HPT site between 2.3 and 2.34, or (2) Use the modified BF+ BIOS and use either the 2.32 or 2.34 drivers.

It seems odd that on the Abit download site, under the drivers section (http://fae.abit.com.tw/eng/download/...pter.htm#HR100), they don't have any HPT drivers with versions that match the HPT BIOS version 2.0.1024 in their BF BIOS. The drivers jump from 2.0.1019 to 2.31. Perhaps the 2.0.1019 are compatible with the 2.0.1024 BIOS, but nothing anywhere tells you that.

From what I've been able to piece together from other posts, it sounds like it's best to install the new drivers BEFORE flashing your BIOS. Since you've already flashed your BIOS, you may want to install the drivers, then reflash your BIOS. Just as an extra layer of caution, though, read this first: http://fae.abit.com.tw/eng/faq/qa/2001/2001070201.htm

Hope this helps and that I haven't just told you a bunch of stuff you already know.

Eggroll
Eggroll is offline   QUOTE Thanks
Old 11-05-02, 04:00 AM Thread Starter   #5
LarryJoe
Member



Join Date: Feb 2002

 
Thank you very much for the thorough reply. I am not sure what I am going to do. All seems fine. Based on your research, it appears I am running the 2.34 BIOS with 2.32 XP drivers. Does anyone see any issues in just leaving it be?

Thanks again EggRoll.

LJ
LarryJoe is offline   QUOTE Thanks
Old 11-05-02, 11:12 AM   #6
Eggroll
Registered



Join Date: Apr 2002

 
LJ,

Perhaps in my thoroughness, I clouded my message. If you are using the offical Abit BF BIOS, then it does not appear you are running the HPT BIOS 2.34. It appears you are running the 2.0.1024 HPT BIOS, which is not the same. If so, it sounds like you would be okay using the 2.32 drivers as they are newer than the 2.0.1024 BIOS. And you do seem to be okay since you state all is fine with your machine.

Maybe if you could reference the post from the mod squad that implies that the official BF BIOS has the 2.34 HPT BIOS, that would help. If it is this thread - http://forum.oc-forums.com/vb/showth...=2.34+AND+BIOS - then arman68's first post might seem to imply the official BF BIOS has the 2.34 BIOS, but I think what he's actually saying there is that updating to the 2.34 BIOS is one of the modifications he made to the new motherboard BIOS he is working on based on the official BF BIOS. The new motherboard BIOS he is working on seems to be something even newer than the BF+ he and annamaria created which, from what I've seen, has the HPT 2.32 BIOS.

Hope this makes sense. Maybe arman68 could chime in to verify.

Good luck,
Eggroll
Eggroll is offline   QUOTE Thanks
Old 11-05-02, 06:33 PM Thread Starter   #7
LarryJoe
Member



Join Date: Feb 2002

 
Thanks again. I went and upgraded to the 2.34 xp drivers before I saw your reply. All still seems OK. Yes, I am running the official BF.

LJ
LarryJoe is offline   QUOTE Thanks
Old 11-05-02, 09:03 PM   #8
maxwedge
Member

 
maxwedge's Avatar 

Join Date: May 2002
Location: CA, USA

 
The HPT 370 BIOS version: 2.0.1024 is from the th7h38 bios from Dec '01.....it's old. Abit has no newer raid bios except maybe in a beta file. The 2.0.1024 is listed here.

__________________
Abit IP35-Pro and a few others
maxwedge is offline   QUOTE Thanks
Old 11-06-02, 02:36 AM   #9
arman68
Member



Join Date: Mar 2002
Location: UK

 
I think it is safe to use the latest HPT drivers (ie: 2.34) with any HPT bios version (from oldest to most recent one).

This also means that if you want to downgrade (!) your bios, you do not need to downgrade your drivers. Beware that downgrading a bios is not recommended: it could render your system unusuable (and it often does). If you are running the HPT 2.3x bios, I would strongly advise against flashing any officiall Abit bios until they start using the 2.3x bioses. Always mod it first to replace the HPT bios (or get the modded bios from this forum)
arman68 is offline   QUOTE Thanks
Old 11-06-02, 04:28 AM Thread Starter   #10
LarryJoe
Member



Join Date: Feb 2002

 
Hmmm...I probably downgraded when I went from
Mf Natural's "d" bios (which had a horriblly slow to detect hpt bios) to the official BF. Guess I got lucky with the mix of xp drivers and the bios downgrade.

Arman68 is correct in noting the dangers. I once tried to upgrade my XP drivers, thinking that the usual rule applies - the latest version available is the best - and my system was hosed. Wouldn't boot into XP.

Thanks all
LarryJoe is offline   QUOTE Thanks
Old 11-06-02, 06:02 AM   #11
Apie!
Registered



Join Date: Apr 2002
Location: Arnhem, The Netherlands

 
I was using the 2.31 bios with th7h_7c (I think) but I replaced the 1024 bios inside the th7h_bf.bin with the latest 2.34 bios. I installed the 2.34 drivers and then flashed the bios. works like a charm....

I used cbrom215 for replacing the highpoint bios btw. can't remember where I got it, but hey, use google
Apie! is offline   QUOTE Thanks
Old 11-06-02, 06:41 AM Thread Starter   #12
LarryJoe
Member



Join Date: Feb 2002

 
Thanks, but I think I am good to go. Like I said, there was one version of the HPT BIOS that took forever to detect the devices, causing an extremely slow boot. This was hard to take for me, because without this hiccup, the Abit BIOS and the XP load were lightening fast. Now I am back to a quick detect. When you are an overclocker and a tweaker, fast reboots are come in handy.

I ran HDTach and the drives on the HTP are where they should be. I don't trust Sandra at all for file system benchmarks.
LarryJoe is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Hardware > Motherboards > Intel Motherboards
Intel Motherboards
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 03:41 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?