Notices

Overclockers Forums > Discussions > Vendor Discussion
Vendor Discussion Likes and Gripes about Vendors. No Post Count.
Forum Jump

really ****ED/SAD

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 09-13-05, 03:13 PM Thread Starter   #1
cooper15
Member



Join Date: Apr 2005

 
really ****ED/SAD


umm has anyone here ever dealt with the company www.softghost.com
. well i placed an order for a x2 4400+ on 9/4/05, cost me $538. they said 48-72 hours to process the order and according to this https://www.softghost.com/cgi-bin/cc...track&secure=Y the company gives FREE 3rd day delivery to anywheree in the usa. now they are based in Wilmington, DE 19805.

and they have yet to provide a tracking number and i still have not recieved this package. i live in MN anyway so it should take only 3 days no matter what.
i have tried calling them onlt ro ALWAYS get their answering machine.they say they will get back to me, well i called last friday and they have yet to call me back I AM NEVER ORDERING FROM THIS COMPANY AGAIN. none of you should either
cooper15 is offline   QUOTE Thanks
Old 09-13-05, 03:46 PM   #2
Mustanley

 
Mustanley's Avatar 

Join Date: May 2003
Location: Asheville, NC (Blue Ridge Mtns)

 
That's sucky, bud, sorry for ya. But this really be posted in the Vendor Discussion section.

Took me almost that long to receive my X2 3800+ and I'm only a 3 hour drive from the place I ordered mine from, and I chose Fedex 2-day. Try calling them again.

__________________
Q9550 on P5Q-Deluxe(460x8.5=3910MHz), 4x2GB GSkill 1066, 750GB WD Black HD, GTX285(702,1512,2592), Blu-ray, Silverstone OP650, Samsung 1080P 50" Plasma + Dell 2408WFP, MX1000 laser mouse, Saitek backlit keyboard, P182, Xigmatek S1283 Black Knight
Mustanley is offline   QUOTE Thanks
Old 09-13-05, 04:10 PM   #3
David
Forums Super Moderator
Overclockers.com Lead Editor



 
David's Avatar 

Join Date: Feb 2001
Location: Hiding from Americans and making pretty colours in a drybox in St Andrews

10 Year Badge
 
Quote:
Originally Posted by Mustanley
That's sucky, bud, sorry for ya. But this really be posted in the Vendor Discussion section
Fixed.

__________________
David J. Nelson MChem(Edin) PhD(Strath) MRSC [ResearcherID: D-3927-2011]
OC Forums Super Moderator // Overclockers.com Editor


The Workhorse: [Lenovo W510] Intel Core i7-720QM / 8 GB DDR3 / nVidia Quadro FX880M / Crucial M4 256 GB SSD / Windows 7
The HTPC/Server: AMD Phenom X4 9650 / 6 GB DDR2 / nVidia 8300 / 5 TB of HDDs / Antec Solo II Case / Windows 7
The Gaming Rig: AMD Llano A6-3650 / 4 GB DDR3 / nVidia GTX260 / 2x 500 GB HDD in RAID0 / Antec Dark Fleet DF-85 Case / Windows 7
The Benchmarking Setup: Various LGA775 chips / Asus Rampage Formula / 2 GB OCZ 1066 MHz DDR2 / nVidia Quadro NVS 285 / 320 GB HDD / Windows 7

My research fellowship is eating all my time, so I may be slow to reply to emails and private messages.
David is offline Author Profile Benching Profile Folding Profile   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Discussions > Vendor Discussion
Vendor Discussion Likes and Gripes about Vendors. No Post Count.
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 06:08 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?