Notices

Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

Windows Update Kills my computer

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 06-25-07, 08:41 AM Thread Starter   #1
dribblesnort
Member

 
dribblesnort's Avatar 

Join Date: Nov 2002
Location: USA

 
Windows Update Kills my computer


So I'm checking out the latest bug fixes and patches at Windows Update Sunday morning and I decide to load the WHQL Drivers offered through Windows Update for my SB Audigy card. Seems innocuous enough, right?

It loads the Game Port Driver fine but when it gets to the Driver for the card itself, my system BSOD's and reboots.

Once it comes back up I have no sound. I go into the Device Mangler and try to remove the sound card so I can reload the drivers. No go. BSOD and reboot again.

Once it BSOD's the second time and reboots, I can then (and only then) remove the sound card from Device Mangler and reinstall via the Driver Disc that came with the Sound Card.

I locate the Original Install CD and reload the drivers. I reboot and get sound.

I go back to the Windows Update site and reinstall the WHQL drivers. Sure enough, BSOD and reboot. Once it reboots there's no sound and I have to perform the previously-mentioned steps to get my sound card to work.

I know that I should avoid the WHQL Drivers like the plague (at least with the current platform I have) but I'm wondering how/why this is occurring because it seems to me that a system shouldn't BSOD and reboot when loading a WHQL Driver.

Anyone else run into a strange issue with Windows Update causing a crash?
dribblesnort is offline   QUOTE Thanks
Old 06-25-07, 08:47 AM   #2
redwraith94
Member

 
redwraith94's Avatar 

Join Date: Feb 2005

 
I have had this happen to two boxes over the years.

One was a nic driver (linksys) that caused the bsod, the other was a sound card driver (creative something or other).

I do not have the foggiest notion why this happens, I also don't know why it hasn't been fixed, when I talk to people about it it is a somewhat rare occurance, out of 2 dozen pcs that I have installed drivers from windows update, only two had the bsod problem.

In general I never use that feature anymore, unless I absolutely cannot find a driver from the manufacturer. It is funny to know that they still haven't fixed this problem.
redwraith94 is offline   QUOTE Thanks
Old 06-25-07, 09:26 AM Thread Starter   #3
dribblesnort
Member

 
dribblesnort's Avatar 

Join Date: Nov 2002
Location: USA

 
Quote:
Originally Posted by redwraith94
I have had this happen to two boxes over the years.

One was a nic driver (linksys) that caused the bsod, the other was a sound card driver (creative something or other).

I do not have the foggiest notion why this happens, I also don't know why it hasn't been fixed, when I talk to people about it it is a somewhat rare occurance, out of 2 dozen pcs that I have installed drivers from windows update, only two had the bsod problem.

In general I never use that feature anymore, unless I absolutely cannot find a driver from the manufacturer. It is funny to know that they still haven't fixed this problem.
I generally avoid loading the device drivers from Windows Update as well, but I thought, "WTHeck? Give it a shot since your audigy drivers are the ones from the install CD and there are surely improvements available by now"

Dumb move on my part.

I used the "Hide this update" feature on Windows Update so I don't see that particular update anymore and make a mistake by trying to load it in the future. (I did that with IE7)
dribblesnort is offline   QUOTE Thanks
Old 06-25-07, 11:47 AM   #4
rainless
Old Member

 
rainless's Avatar 

Join Date: Jul 2006
Location: CHI-Town Love is alive in Spain

 
Quote:
Originally Posted by dribblesnort
So I'm checking out the latest bug fixes and patches at Windows Update Sunday morning and I decide to load the WHQL Drivers offered through Windows Update for my SB Audigy card. Seems innocuous enough, right?

It loads the Game Port Driver fine but when it gets to the Driver for the card itself, my system BSOD's and reboots.

Once it comes back up I have no sound. I go into the Device Mangler and try to remove the sound card so I can reload the drivers. No go. BSOD and reboot again.

Once it BSOD's the second time and reboots, I can then (and only then) remove the sound card from Device Mangler and reinstall via the Driver Disc that came with the Sound Card.

I locate the Original Install CD and reload the drivers. I reboot and get sound.

I go back to the Windows Update site and reinstall the WHQL drivers. Sure enough, BSOD and reboot. Once it reboots there's no sound and I have to perform the previously-mentioned steps to get my sound card to work.

I know that I should avoid the WHQL Drivers like the plague (at least with the current platform I have) but I'm wondering how/why this is occurring because it seems to me that a system shouldn't BSOD and reboot when loading a WHQL Driver.

Anyone else run into a strange issue with Windows Update causing a crash?
Sure that happened to me. Of COURSE a driver can cause BSOD. Drivers are, in fact, the NUMBER ONE cause of BSOD. I think the exact same thing happened to me: Windows update, sound card driver, BSOD. From then on (and before that moment too) I only get drivers from the sound card manufacturer. Because these WHQL drivers are just some crap Microsoft themselves put together "hoping" it might work.

__________________
Core 4 Q9550 @4003mhz 1.30v
Core 2 Duo e8400 @ 4.6ghz 1.328v (E0 Stepping)
Core 2 Duo E6400 @ 3.8ghz 1.525v
Asus P5Q Pro 2002m @ 515x9 .63x 1.52
OCZ Fatal1ty Edition 4GB DDR2 5-4-4-18 @ 2.18v w/OCZ XTC Ram Cooler
Corsair 750TX PSU
Sparkle 260 GTX (65nm, 216) 696c 1512s 999mem
BLOCK: Swiftech Apogee GTZ RAD: BIXII REZ: MCRES-Micro rev2 PUMP: Pondmaster 750 FAN: 2 HS Yates CONTROLLER: Modified Evercool WC-202
rainless is offline   QUOTE Thanks
Old 06-25-07, 03:32 PM   #5
AngelfireUk83
Member

 
AngelfireUk83's Avatar 

Join Date: Nov 2004
Location: England

 
I have been sorting out my PC so I have only just read this now I would of said AVOID any drivers that show up in Windows Update. I did this once for my old nForce2 Ultra's audio I updated the driver that came up and I got the same thing.

In the end I removed it and I went to find out if there was a newer driver on nVidia's site my advice would be to use this as info that there's a newer driver and I would go to the official site. Usually there realease a package normally WU just provides a certain file when its really needed loads of files thats better than the current ones installed.

__________________
OS: Windows 7 Ultimate 64bit SP1
Board: Gigabyte Z68AP-D3 Rev.1 F8
CPU: INTEL i7 2600k 3.40ghz (Stock)
RAM: Crucial Ballistix Elite 8GB 1866mhz DDR3 (1600mhz@1.60v)
OS Storage: Crucial 128GB M4 SSD (FW 040H)
Spare Storage: Seagate 500GB 7,200rpm, Hitachi 1TB 7,200rpm (Back-Up HDD)
GPU/Audio: HIS 7850 2GB GDDR5 PCI-E Card (OC: 920/1270)
PSU: OCZ Fatality 750w Modular PSU
Optical: LG GH24NS90 24x DVD-RW
AngelfireUk83 is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 06:59 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?