Notices

Overclockers Forums > Hardware > Video Cards > AMD (ATI) GPUs
AMD (ATI) GPUs
Forum Jump

HD4870 Performance Issues?

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 10-30-08, 10:27 PM Thread Starter   #1
utopiafallen
New Member



Join Date: Oct 2008

 
HD4870 Performance Issues?


I just recently completed a new build and have been playing Assassin's Creed patched to 1.02. Judging by the reviews on my card, I should not be having any real performance issues, but I am.

I have all the settings maxed running at 1680x1050 with VSync off and I get pretty steep framerate dips at certain points, particularly noticeable when doing a bird's eye view of Damascus from one of the viewing towers. Doing a leap of faith off one of those towers also has severe stuttering during the leap up into the air sequence when the camera zooms out pretty far.

Here's my build:
Phenom X4 9950BE 125W
Asus M3A79-T Deluxe
Diamond HD 4870 1GB
Corsair Dominator 2x2GB DDR2-1066 5-5-5-15
Western Digital 640GB
Xclio 1000W PSU
Vista Business SP1 64-bit
Catalyst 8.10 w/o Hotfix

So I've got two questions:
1. What performance should I be expecting from this build in Assassin's Creed v1.02?
2. Am I doing something wrong to cause the stuttering and framerate dips? Setting Multisampling to 1 reduces the dips significantly as well as setting Shadows to 2, but I was under the impression that I should be able to handle those settings maxed at my resolution.

Thanks for any help.
utopiafallen is offline   QUOTE Thanks
Old 10-30-08, 10:28 PM   #2
SeanBest
Member

 
SeanBest's Avatar 

Join Date: Aug 2006
Location: Harrisonburg, VA

 
1. Not sure, don't own the game for pc.
2. What driver version?

Video drivers can cause frame rate problems as well as game patching, that game's been out awhile so I'd think more a driver problem.

__________________
HEAT
Motherboard --------- BIOSTAR TPower I45
CPU ------------------- Intel E8600 @ 4GHz
Memory -------------- 4GB Corsair Dominator DDR2 1066
Cooling --------------- Thermalright Ultra 120 Extreme
HDDs ----------------- Western Digital Velociraptor 300GB 10k RPM
Graphics Card ------- MSI HD4870 OC Edition
Soundcard ----------- Creative X-Fi Xtremegamer
Case ------------------ Antec Nine Hundered
Power Supply -------- OCZ ModXStream Pro 600W
OS -------------------- Win 7 Pro x64, Mint Debian x64
SeanBest is offline Heatware Profile   QUOTE Thanks
Old 10-30-08, 10:57 PM Thread Starter   #3
utopiafallen
New Member



Join Date: Oct 2008

 
Quote:
Originally Posted by utopiafallen View Post
Catalyst 8.10 w/o Hotfix
:P
utopiafallen is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Hardware > Video Cards > AMD (ATI) GPUs
AMD (ATI) GPUs
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 11:52 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?