Notices

Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

.NET Framework / ATI Catalyst Control Center Problem

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 02-02-11, 12:03 AM Thread Starter   #1
DBean23
New Member



Join Date: Feb 2011

 
.NET Framework / ATI Catalyst Control Center Problem


Hi everybody, I have a machine I am working on that has a problem I want to fix.

The problem shows itself upon startup. As soon as Windows XP finishes loading to the desktop, a window appears showing the error message. It is titled, "Cli.exe - .NET Framework Initialization Error." It states inside the window, "Unable to find the version of runtime to run this application." This window also pops up when I try to open the graphics card controlling program ATI Catalyst Control Center.

I just formatted one of this machine's hardrives and then installed a fresh install of Windows XP on it. I installed SP3 over the SP1a version that came on the Windows XP CD first. Then I think I might have installed the motherboard drivers. Then I think I updated Windows Update and let it run to get me .NET Framework. Then I installed the ATI graphics card display driver and ATI Catalyst Control Center. Specs of computer: AMD Athlon XP3000+ Asus A7N8X motherboard, 1.5 GB ram, 80 GB and 60 GB hard drives, 1 CD-RW drive, 1 CD-RW and DVD rom drive, Windows XP Home 32 bit, and ATI 9250 Graphics Card.

Appreciate any help!
DBean23 is offline   QUOTE Thanks
Old 02-02-11, 01:25 AM   #2
redduc900
Super Moderator
First Responders

 
redduc900's Avatar 

Join Date: Dec 2000
Location: WCG@home in Portland

10 Year Badge
 
Uninstall all instances of .NET from your PC, then use the .NET Framework Cleanup Tool to remove any remaining remnants...

http://blogs.msdn.com/b/astebner/arc...8/8904493.aspx

... after which download the .NET framework directly from MS, instead of using Windows Update to install it for you automatically. And make sure to read this first before using the cleanup tool...

http://blogs.msdn.com/b/astebner/arc...7/8108332.aspx

redduc900 is online now   QUOTE Thanks
Old 02-02-11, 12:01 PM   #3
madhatter256
Special Member ★

 
madhatter256's Avatar 

Join Date: Jul 2008
Location: CFL

 
You can try this as well:

-Uninstall ATI Catalyst Control Center, or the whole ATI package if you cannot.
-Then download and run this nifty program: .NET Automated Removal, which will remove all versions of .net framework in XP.

When that is done, simply download .NET 3.5 and that will cover 1.0 through 2.0.
Finally, reinstall ATI CCC or the whole software package again.
See if that helps.

__________________
Folding User Stats
Heatware
madhatter256 is offline Folding Profile Heatware Profile   QUOTE Thanks
Old 02-02-11, 05:29 PM Thread Starter   #4
DBean23
New Member



Join Date: Feb 2011

 
Thanks to both of you for your help so far. I decided to run the .Net Framework Cleanup Tool and it successfully deleted all of my .Net Framework files. Next I ran the Windows Update Website Program to help me install .Net Framework. It found .Net Framework 4.0 Client. However, when I tried to install it it failed. The description of the problem was this: "Installation Failure" and "Error Code: 0x643". This has got me thinking that there may be a bigger problem.

It game me the option to contact a Microsoft professional via E-mail so I have started the process. This was the message I wrote him/her:

Hi, I just reformatted my computer's harddrives and installed Windows XP Home 32-bit on one of them. The .Net Framework program wasn't being compatible with my ATI Catalyst Center graphics settings controller program. An error would appear titled, "Cli.exe - .Net Inititialization Error" and which said, "Unable to find the version of runtime to run this application." This error window would appear once I was loaded into the desktop of the OS everytime. Also this same window-error appearred when I would try to open up the ATI CCC program. I couldn't get into the program after the message appearred either. To attempt to fix this I downloaded, installed, and ran a .Net Framework Cleanup Tool successfully. Then I tried to use Windows Update to install the 4.0 .Net Framework Client program, but it didn't install successfully. Windows Update gave me this description of the problem: it called it an "Installation Failure" and stated: Error Code: 0x643. I am looking for assistance to how to install this program and/or fix a deeper/more complicated system problem.

I'll try installing 4.0 .Net Framework after downloading it directly from MS' website.
DBean23 is offline   QUOTE Thanks
Old 02-02-11, 05:52 PM Thread Starter   #5
DBean23
New Member



Join Date: Feb 2011

 
I just downloaded 4.0 .Net Framework Client program from MS' website and tried isntalling it. Again, I also got an installation error; it failed to install. It did have an installation log report, but I don't think I would have much success trying to read it myself.
DBean23 is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 03:13 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?