Notices

Overclockers Forums > Hardware > Storage
Storage SSDs, HDDs, CD/DVD/Bluray
Forum Jump

USB hard drive (no longer) show up

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 01-13-12, 10:07 AM Thread Starter   #1
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
Question USB hard drive (no longer) show up


I have been using this new external Western Digital My Passport Essential 1TB USB drive for a month with my laptop. Sometimes it would just show up quickly after being plugged into one of the 4 USB ports. Sometimes it will beep for up to a minute before it show up under "My Computer" along side the C: drive.

Today, it just won't show up. I had disconnected it and reconnected it many times, each time it will beep for a while like it used to but when the beeping stops... it still wouldn't show up beside the C drive.

I've checked under Device Manager, it is there under both USB controllers(as USB mass storage device) and Disk drives(as WD My Passport 0740 USB Device).
But it is not under Disk Management, where only C drive is visible.

I am on Windows 7 Home 64bit. What can I do to make it reappear?
OC101 is offline   QUOTE Thanks
Old 01-13-12, 02:40 PM   #2
RGone
Senior DFI Staff

 
RGone's Avatar 

Join Date: Apr 2004
Location: JAX, Mississauna

 
I would try the drive in another Usb port and having more than one computer as I do...I would immediately try the drive on another computer altogether to see if it has died.

__________________
You May Need Help = We Need Info to Help.
MOBO > Model and Bios version.
CPU & Cooler > Be Specific.
MEMORY > Manufacturer & P/N & Size.
POWER SUPPLY > Manufacturer & Wattage.
VIDEO CARD > Make/Model/How Many.
HDDs/Optical drives > How Many? SSD? Raid/No Raid?
SOUND DEVICE > Onboard or Add-in?
USB > Usb Devices Plugged to Mobo?
O/S > Win? SP? Linux?
Case > Brand/Model/Fans Installed?
Institute of Level Headed Over Clockers
RGone is offline   QUOTE Thanks
Old 01-13-12, 03:59 PM Thread Starter   #3
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
Quote:
Originally Posted by RGone View Post
I would try the drive in another Usb port and having more than one computer as I do...I would immediately try the drive on another computer altogether to see if it has died.
I have tried it on all 4 USB ports with no luck. Other devices still work on these ports.

Unfortunately, I do not have another computer to t ry.  I am out of the country at this moment with m y laptop only.   
OC101 is offline   QUOTE Thanks
Old 01-13-12, 04:42 PM   #4
RGone
Senior DFI Staff

 
RGone's Avatar 

Join Date: Apr 2004
Location: JAX, Mississauna

 
Quote:
Originally Posted by OC101 View Post
I have tried it on all 4 USB ports with no luck. Other devices still work on these ports.

Unfortunately, I do not have another computer to t ry.  I am out of the country at this moment with m y laptop only.   
Unfortunately, it sounds as if you have been had again by the fickle finger of fate and it surely sounds like the Usb drive is failed. No way to verify since you are without a 'test' computer.

__________________
You May Need Help = We Need Info to Help.
MOBO > Model and Bios version.
CPU & Cooler > Be Specific.
MEMORY > Manufacturer & P/N & Size.
POWER SUPPLY > Manufacturer & Wattage.
VIDEO CARD > Make/Model/How Many.
HDDs/Optical drives > How Many? SSD? Raid/No Raid?
SOUND DEVICE > Onboard or Add-in?
USB > Usb Devices Plugged to Mobo?
O/S > Win? SP? Linux?
Case > Brand/Model/Fans Installed?
Institute of Level Headed Over Clockers
RGone is offline   QUOTE Thanks
Old 01-13-12, 05:45 PM Thread Starter   #5
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
It actually shows up in Disk Management as Disk 1, but it is "Not Initialized", and "Initialize" is not an option at the moment... it was available earlier but it gave me "I/O error" when I clicked on it.
The light on the disk flashes all the time like if it is being accessed.
OC101 is offline   QUOTE Thanks
Old 01-13-12, 06:21 PM   #6
RGone
Senior DFI Staff

 
RGone's Avatar 

Join Date: Apr 2004
Location: JAX, Mississauna

 
I g00gled those Usb external drives and just like last time I did, the net is full of problems with them. You likely do not have another cable with you to connect drive to computer but that seems to be an issue with many problems for users. Many had to go to a shorter cable.

__________________
You May Need Help = We Need Info to Help.
MOBO > Model and Bios version.
CPU & Cooler > Be Specific.
MEMORY > Manufacturer & P/N & Size.
POWER SUPPLY > Manufacturer & Wattage.
VIDEO CARD > Make/Model/How Many.
HDDs/Optical drives > How Many? SSD? Raid/No Raid?
SOUND DEVICE > Onboard or Add-in?
USB > Usb Devices Plugged to Mobo?
O/S > Win? SP? Linux?
Case > Brand/Model/Fans Installed?
Institute of Level Headed Over Clockers
RGone is offline   QUOTE Thanks
Old 01-14-12, 02:13 AM Thread Starter   #7
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
The cable come with the drive is only about a foot long. That is quite short.
OC101 is offline   QUOTE Thanks
Old 01-14-12, 02:20 AM   #8
RGone
Senior DFI Staff

 
RGone's Avatar 

Join Date: Apr 2004
Location: JAX, Mississauna

 
Quote:
Originally Posted by OC101 View Post
The cable come with the drive is only about a foot long. That is quite short.
I would certainly say it is not 'too' long at any rate. Apparently there were some of those drives that shipped with cables too long. Maybe the cable has seen one too many twists in use?

What operating system are you using that Usb drive with while you are not at home?

__________________
You May Need Help = We Need Info to Help.
MOBO > Model and Bios version.
CPU & Cooler > Be Specific.
MEMORY > Manufacturer & P/N & Size.
POWER SUPPLY > Manufacturer & Wattage.
VIDEO CARD > Make/Model/How Many.
HDDs/Optical drives > How Many? SSD? Raid/No Raid?
SOUND DEVICE > Onboard or Add-in?
USB > Usb Devices Plugged to Mobo?
O/S > Win? SP? Linux?
Case > Brand/Model/Fans Installed?
Institute of Level Headed Over Clockers
RGone is offline   QUOTE Thanks
Old 01-14-12, 02:56 AM Thread Starter   #9
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
Windows 7 Home 64bit
OC101 is offline   QUOTE Thanks
Old 01-26-12, 11:46 AM Thread Starter   #10
OC101
Member

 
OC101's Avatar 

Join Date: Oct 2007

 
I tried it on someone else's computer yesterday. It worked just fine on two different computers. It showed up nicely and quickly under "My computer" on both computers without beeping, and I was able to read and write files to it just fine.

Then today, I tried it again on my computer, I was able to get it to not beeping at all when it was plugged...then under disk manager, it showed up differently than before. Before, it was either invisible, or show up but "not initialized", and the disk size wasn't reported at all. This time, it showed up as initialized, so after I assigned a different letter to it, it started to work. Only for a few hours. Then it started to beep again, and it disappeared under "My computer" after a system reboot. Now it is "not initialized" again.

So what is really going on? How can I fix it?
OC101 is offline   QUOTE Thanks
Old 10-16-13, 07:52 PM   #11
slatter
New Member



Join Date: Oct 2013

 
i have the same problem but couldn't find any solution to retrieve my files. I need help in retrieving my files
slatter is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Hardware > Storage
Storage SSDs, HDDs, CD/DVD/Bluray
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 08:05 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?