Notices

Overclockers Forums > Software > Alternative Operating Systems
Alternative Operating Systems Linux, Mac, Unix Operating Systems and Applications
Forum Jump

Debian Nvidia can't configure resolution

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 02-28-12, 06:56 PM Thread Starter   #1
minoukat
Member



Join Date: Jul 2001
Location: Ottawa, Ontario

10 Year Badge
 
Debian Nvidia can't configure resolution


Hey guys, I've just installed Debian 6 amd64 Stable on my desktop running an Nvidia Quadro NVS 290 graphics card. So far, I've had experience with Ubuntu 10.04 on my laptop (with an NVidia 7150M chip), and it's been working fine and nice, so I thought I'd give Debian a try (I'm thinking of migrating my server to Debian )

Anyways, after fighting with the system to install the official Nvidia drivers, I got them on (some conflict with the Nouveau drivers was preventing me to install in X, so I learned about Ctrl-Alt-F1 ) Got that out of the way, drivers installed.

During driver installation, it gave me some warning about the version of gcc being incompatible (I checked and it's version 4.4.5). Installation finished and I rebooted.

Now the X configuration is messed up with the only resolutions available being 320x240 and 640x480.

I tried manually configuring the Xorg.conf file but either a) I don't know how or b) whatever I'm doing is not working.

I also tried running dpkg-reconfigure xserver-xorg and it does nothing.

I'm running out of ideas, and having linux run at VGA resolutions on a 24in widescreen monitor with native resolution 1920x1080 is quite painful.

Can anybody help me configure my install?

__________________
The only thing you should expect is the unexpected.
minoukat is offline   QUOTE Thanks
Old 02-28-12, 07:01 PM   #2
Stratus_ss
Overclockix Snake Charming Senior
Alt OS Content Editor

 
Stratus_ss's Avatar 

Join Date: Jan 2006
Location: Ontario Canada

 
can you post up your xorg.conf, /var/log/nvidia-installer.log, /var/log/Xorg.0.log and /var/log/syslog (or messages depending on your system)

__________________
HEAT
Those wishing to contribute to the AltOS section front page please PM me.

Leviathan41: "Playing with a controller because the mouse and keyboard is too easy is like racing with a bicycle because a car is too fast."

Chris Fisher "Windows is like Administration with training wheels"
Stratus_ss is offline Author Profile Folding Profile Heatware Profile   QUOTE Thanks
Old 02-28-12, 07:47 PM   #3
Shelnutt2
Overclockers Team Content Editor

 
Shelnutt2's Avatar 

Join Date: Jun 2005
Location: /home/

 
try nvidia-xconfig,

also what xorg version are you running?

__________________
Build!.Borg!.Recruit!.Folding.for.Team.32!
Gigabyte P35-DS3R, E6300, 2x512MB Team Group DDR2 667, EVGA 7800GT Heat

Want to run the folding@home gpu client in linux?
www.linuxfah.info

Your teacher is a dumbass. The equation is exact. ~Frodo Baggins
Damn....It's 12:00 AM and I thought my 805 would be a magic pumkin and turn into a conroe.........boy was I fooled:) ~Stilletto
This is what I get for not only being a newb, but also disregarding instructions! ~ShadowPho
I hate women... but im not gay lol. ~MrCrowley
Love can fade but knowledge stays forever (unless you develop alzheimers). ~Constantinos
Shelnutt2 is offline Folding Profile   QUOTE Thanks
Old 02-28-12, 08:31 PM Thread Starter   #4
minoukat
Member



Join Date: Jul 2001
Location: Ottawa, Ontario

10 Year Badge
 
I attached the log files as I can't post them straight in here (seems like they're way too long ).

thanks for the reply guys

EDIT: I don't quite know how to check the version of Xorg.... I'm running the version installed on Debian 6.0.4 (latest version downloadable from Debian.org)
Attached Files
File Type: gz home.tar.gz (165.5 KB, 10 views)

__________________
The only thing you should expect is the unexpected.

Last edited by minoukat; 02-28-12 at 08:37 PM.
minoukat is offline   QUOTE Thanks
Old 02-29-12, 05:40 AM   #5
Stratus_ss
Overclockix Snake Charming Senior
Alt OS Content Editor

 
Stratus_ss's Avatar 

Join Date: Jan 2006
Location: Ontario Canada

 
So after looking at the logs you posted up, I noticed (as you stated) that the kernel couldn't build the module properly
Don't ignore this error:
Quote:
The compiler used to compile the kernel (gcc 4.3) does not exactly match the
current compiler (gcc 4.4). The Linux 2.6 kernel module loader rejects
kernel modules built with a version of gcc that does not exactly match that of
the compiler used to build the running kernel.
It tells you everything you need to know!

To fix this you can try the following:
Quote:
1) aptitude install gcc-4.3

2) when it's done, cd /usr/bin

3) unlink gcc (this deletes the symlink currently created)

4) ln -s /usr/bin/gcc-4.3 /usr/bin/gcc

5) install the nvidia driver as you tried before.

6)in the /etc/default/grub file modify the

GRUB_CMDLINE_LINUX_DEFAULT line to look like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet modeset=0"

7) run "update-grub" (this is important because otherwise you will not have this setting applied at boot

8)reboot in recovery (single-user) mode

9) sudo sh NVIDIA<driver>.run --uninstall
sudo sh NVIDIA<driver>.run

10) Reboot

Also this is in your xorg logs:
Code:
(WW) Feb 28 20:54:08 NVIDIA(0): No valid modes for "1920x1080"; removing.
(WW) Feb 28 20:54:08 NVIDIA(0): 
(WW) Feb 28 20:54:08 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Feb 28 20:54:08 NVIDIA(0):     "nvidia-auto-select".
(WW) Feb 28 20:54:08 NVIDIA(0): 
(II) Feb 28 20:54:08 NVIDIA(0): Validated modes:
(II) Feb 28 20:54:08 NVIDIA(0):     "nvidia-auto-select"
(II) Feb 28 20:54:08 NVIDIA(0): Virtual screen size determined to be 640 x 480
(WW) Feb 28 20:54:08 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
I believe this is due to a lack of kernel module which should be fixed by following the steps above

__________________
HEAT
Those wishing to contribute to the AltOS section front page please PM me.

Leviathan41: "Playing with a controller because the mouse and keyboard is too easy is like racing with a bicycle because a car is too fast."

Chris Fisher "Windows is like Administration with training wheels"
Stratus_ss is offline Author Profile Folding Profile Heatware Profile   QUOTE Thanks
Old 02-29-12, 12:33 PM Thread Starter   #6
minoukat
Member



Join Date: Jul 2001
Location: Ottawa, Ontario

10 Year Badge
 
Ok thanks Stratus! I really appreciate you taking the time to look through my logs I did what you suggested and indeed, the installation went well with gcc 4.3. However, the display modes were unchanged.

After some tweaking and setting a huge virtual mode in Xorg.conf, I managed to get a resolution of 1360xsomething but not the 1920x1080 that I want! Every time I add the changes manually to the Xorg.conf, they get ignored/removed.

I checked the correct modeline using 'cvt 1920 1080' then added it using xrandr, and finally added it to xorg.conf. The mode is displayed in xrandr but not available in nvidia-settings.

What's going on here? why are my settings being ignored?

Thanks for all your help!

__________________
The only thing you should expect is the unexpected.
minoukat is offline   QUOTE Thanks
Old 02-29-12, 01:34 PM   #7
Stratus_ss
Overclockix Snake Charming Senior
Alt OS Content Editor

 
Stratus_ss's Avatar 

Join Date: Jan 2006
Location: Ontario Canada

 
No problem,

everytime you come back with something new please re-up the logs?

try adding this
Code:
Option "UseEDIDFreqs" "FALSE"
Option "UseEDIDDpi" "FALSE"
to your xorg.conf under the "screen" section

alternatively you can try putting this:
Code:
Option "ModeValidation" "NoEdidModes"
Option "UseEDIDFreqs" "FALSE"
under "Device" section. I would try one and then the other, just so you know which one may do it

NOTE: "UseEdid" "FALSE" disables sound over HDMI.

As a dead last alternative you can try this script It used to work for debian, and the last updated time was Jan 2012 so it should work if nothing else does

__________________
HEAT
Those wishing to contribute to the AltOS section front page please PM me.

Leviathan41: "Playing with a controller because the mouse and keyboard is too easy is like racing with a bicycle because a car is too fast."

Chris Fisher "Windows is like Administration with training wheels"
Stratus_ss is offline Author Profile Folding Profile Heatware Profile   QUOTE Thanks
Old 03-03-12, 07:31 AM   #8
habbajabba
Member



Join Date: Oct 2005

 
You need to be root to change the default res in some distros. It should work fine after a reboot. I use the 290.20 nvidia drivers and the file is named nvidia-settings in bin.

__________________
Intel Northwood @3.06 GHz
Biostar microatx
2 GB DDR2 675
Evga 8400gs
Samsung 2232GW 2ms 22"
Altec Lansing 2.1 speakers
Memorex ext usb burner
Win7Ult 32bit/Manjaro dualboot
WD cav blue 320gb
Samsung F4 2tb
WD Blue 2tb
CP850avrlcd ups
habbajabba is offline   QUOTE Thanks
Old 03-12-12, 01:25 AM Thread Starter   #9
minoukat
Member



Join Date: Jul 2001
Location: Ottawa, Ontario

10 Year Badge
 
Thanks guys! After performing Stratus' changes, I realized that I the monitor was actually not being detected because the signal was going through a cheap KVM. So I plugged the card directly into the monitor, reran the nvidia xconfig and it worked! Now everything looks good!

Thanks again for all your help, especially Stratus!

__________________
The only thing you should expect is the unexpected.
minoukat is offline   QUOTE Thanks
Old 03-12-12, 11:42 AM   #10
Stratus_ss
Overclockix Snake Charming Senior
Alt OS Content Editor

 
Stratus_ss's Avatar 

Join Date: Jan 2006
Location: Ontario Canada

 
Just glad that you got everything working to your satisfaction!
Stratus_ss is offline Author Profile Folding Profile Heatware Profile   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Software > Alternative Operating Systems
Alternative Operating Systems Linux, Mac, Unix Operating Systems and Applications
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 06:16 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?