Why Does The BIOS Not Pick Up My Hard Drives?

Add Your Comments

I’ve gotten a couple letters like the following:

Bios will not find my maxtor Ultra DMA 66 HD, I have 4 IDE connections
on my board and 2 are for Ultra DMA HDs. Highpoint sees the HD and I even loaded Windows after formating, Why
the hell is my bios not finding it?????

I’ve tried just about everything next to throwing it out the window….
I have a P II in there and someone said it might be because it’s not a
P III ????????

I have tried sending E-mails to Tech sup. and they are all out to
lunch…

Actually, it’s working just the way it’s supposed to work.

When you get more than two IDE slots on a motherboard, whether it’s RAID or just some Ultra100 slots, those extra slots are controlled by
an add-on controller. It may be built into the motherboard, but electronically, it’s still an add-on controller.

During initial bootup, the BIOS only recognizes those drives connected to IDE 1 and 2. That’s it. An IDE (or SCSI) controller then takes over and adds the drives controlled by it.

So not seeing any hard drives hooked into those controller slots is perfectly normal, and your machine is functioning the way it’s supposed to. Right now, I have a hard drive hooked into one of the Asus A7V’s Ultra 100 slots, and the Asus BIOS doesn’t recognize that, either.

So How Do I Boot?

Simple enough. Your motherboard BIOS should give you options as to where to boot from. If you wish to boot from a device attached to an IDE/RAID controller, you simply indicate that you want to boot from the SCSI controller (even though you don’t have a SCSI hard drive; these controllers fool the motherboard into thinking you have something like a SCSI controller attached.

Make sure that if you are going to boot off such a drive, that you make the first partition of the drive (or, in the case of RAID, an array) the active partition.

Email Ed


Leave a Reply

Your email address will not be published. Required fields are marked *