Notices

Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

Vista 64 bit beta driver for Nostromo N52

Post Reply New Thread Subscribe Search this Thread
 
 
Thread Tools
Old 03-31-07, 08:58 PM Thread Starter   #1
Sniper.nkc
Member



Join Date: Feb 2002
Location: Palmdale CA

 
Vista 64 bit beta driver for Nostromo N52


Belkin released a Vista 64 bit beta driver for Nostromo N52 speedpad.

1. Download 64 bit driver here
2. Select Windows 64 bit Beta and save file.
3. Disable UAC by going into MSconfig and tools, look down to find disable UAC, click the command launch. You will get a C prompt saying command is done. Reboot.
4. Plug in N52 and load the driver 64 bit beta. Controller profile is now enable and you can load your game profile.
5. In the device manager, verify your N52 speedpad is connected without any yellow ! . If you have this yellow ! , click on the properties for each device and see if you get this message: "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"
6. To solve step # 5, reboot your computer and keep pressing F8 to get into that windows boot selection screen, With vista there are more options here. You want the last option that says something about turning off the driver signing. Now once you go into windows, those yellow ! will be gone from the device manager and your nostromo profile manager should work fine.
7. Optional: Enable UAC in MSCONFIG.

Belkin finally listened to our call and fixed the controller profile program. Now you can load your game profile. My BF2 game profile works great.

__________________
CPU: AMD 1090T Black EditionThuban
Cooler: Corsair H50 Hydro Series (push/pull)
MB: Asus Crosshair IV Formula 890FX
SSD: OCZ Vertex 2 60 Gb
HD: 2 x WD Caviar Blue (Raid 0)
Mem: OCZ Gold series DDR3-1600
GPU: Sapphire HD 6970 in CrossfireX
PS: Corsair HX1000W Modular
Case: AZZA Solano 1000

Last edited by Sniper.nkc; 04-19-07 at 06:26 AM.
Sniper.nkc is offline   QUOTE Thanks
Old 04-03-07, 04:59 PM   #2
ScottAdams
New Member



Join Date: Apr 2007

 
Not available


When I go to the link, there are no Vista drivers listed.

I have been waiting since January for the darn fix for my N52...

I did find a pointer to a driver called "Nostromo_v3g" from the Belkin site. But, following the instructions above... nada.

Any advice or maybe I am missing something simple?
Scott
ScottAdams is offline   QUOTE Thanks
Old 04-03-07, 09:38 PM Thread Starter   #3
Sniper.nkc
Member



Join Date: Feb 2002
Location: Palmdale CA

 
If you click on the link you will see this:

Nostromo Programming Software and Drivers:

Nostromo Programming Software and Drivers Date Ver OS
3/15/07 Windows 64 bit BETA Windows XP

3/26/07 3.0d Windows 2000, Windows ME, Windows XP, Windows 98 SE


Click on the beta 64 bit. I edited the 1st post and removed "Vista." This driver works with Vista.


WELCOME TO THE FORUM!

__________________
CPU: AMD 1090T Black EditionThuban
Cooler: Corsair H50 Hydro Series (push/pull)
MB: Asus Crosshair IV Formula 890FX
SSD: OCZ Vertex 2 60 Gb
HD: 2 x WD Caviar Blue (Raid 0)
Mem: OCZ Gold series DDR3-1600
GPU: Sapphire HD 6970 in CrossfireX
PS: Corsair HX1000W Modular
Case: AZZA Solano 1000

Last edited by Sniper.nkc; 04-03-07 at 09:46 PM.
Sniper.nkc is offline   QUOTE Thanks
Old 04-06-07, 07:46 PM   #4
eXphile
New Member



Join Date: Apr 2007

 
Can't get he driver to work for Vista 64-Bit


Hi There!

I was a happy guy when I read that you had a way to the the 64 bit XP driver to work in Vista 64 bit. I have to boot in XP to play most of my games, which I am not happy about, as I cannot play without my n52!

BUT I could not get it to work. I followed the steps you outlined, and the driver installed. In the hardware manager, the system even saw it as a Nostromo n64 Speedpad rather than a generic HID. BUT it said the driver was not valid.

Exact Message in the properties box for the n52:

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Now, I did get prompted the first time I tried this (I uninstalled and reinstalled a couple of times) that this was not a digitally signed driver, but canceled it.

Any advice on what I did wrong as the Loadout Manager still does not see the n52 as there!! I am so close yet so far...

Thanks!!!
eXphile is offline   QUOTE Thanks
Old 04-06-07, 11:14 PM Thread Starter   #5
Sniper.nkc
Member



Join Date: Feb 2002
Location: Palmdale CA

 
Quote:
Originally Posted by eXphile
Hi There!

I was a happy guy when I read that you had a way to the the 64 bit XP driver to work in Vista 64 bit. I have to boot in XP to play most of my games, which I am not happy about, as I cannot play without my n52!

BUT I could not get it to work. I followed the steps you outlined, and the driver installed. In the hardware manager, the system even saw it as a Nostromo n64 Speedpad rather than a generic HID. BUT it said the driver was not valid.

Exact Message in the properties box for the n52:

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)


Now, I did get prompted the first time I tried this (I uninstalled and reinstalled a couple of times) that this was not a digitally signed driver, but canceled it.

Any advice on what I did wrong as the Loadout Manager still does not see the n52 as there!! I am so close yet so far...

Thanks!!!


Before you install the new driver, please make sure you have uninstalled any Nostromos driver, then reboot before installing the new driver. Also, during the installation it will give you a warning "driver not digitally signed", go ahead and give it permission to install. Do not click on cancel at this point.


I went into my computer device manager and click on properties for Nostromos N52 HID Speedwheel 2.0/Mouse Wheel (I have two devices here) and found this in driver tab:

Driver Provider: Belkin Corporation

Driver date: 7/21/2003

Driver version: 3.0.0.9

Digital signer: Not digitally signed

Does this information match what you have? If not, it did not install correctly.

__________________
CPU: AMD 1090T Black EditionThuban
Cooler: Corsair H50 Hydro Series (push/pull)
MB: Asus Crosshair IV Formula 890FX
SSD: OCZ Vertex 2 60 Gb
HD: 2 x WD Caviar Blue (Raid 0)
Mem: OCZ Gold series DDR3-1600
GPU: Sapphire HD 6970 in CrossfireX
PS: Corsair HX1000W Modular
Case: AZZA Solano 1000

Last edited by Sniper.nkc; 04-06-07 at 11:20 PM.
Sniper.nkc is offline   QUOTE Thanks
Old 04-09-07, 09:26 PM   #6
eXphile
New Member



Join Date: Apr 2007

 
OK, this almost makes we want to bag Vista, but for the dual boot on my old XP drive.

Now, once I uninstalled all drivers for the n52, rebooted then try to re-install, it still does not work. I get the stupid driver rollback error at the end of the installation and it would install.

I was so close the first time and this worked. Stupid "digital signing prompt" I got on the first attempt made it sound like the driver could not be installed because it was not digitally signed. Stupid Microsoft and stupid Belkin.

*sigh*

Back to XP I go to play games until stupid Belkin releases real Vista 64 drivers instead of goofy XP 64 drivers.

"Vista - THE PC gaming platform" - bah!
eXphile is offline   QUOTE Thanks
Old 04-09-07, 10:19 PM Thread Starter   #7
Sniper.nkc
Member



Join Date: Feb 2002
Location: Palmdale CA

 
I was getting roll backs during installtion at about 75% completion. It actually rolled back the installtion. It was weird to see that. The 64 bit didn't install for me at first, but then I realized I didn't have my N52 speedpad connected to my computer during the installtion. Once I made the connection and did another set-up install, it was success for me. Sorry this is not working for you. Keep trying.

__________________
CPU: AMD 1090T Black EditionThuban
Cooler: Corsair H50 Hydro Series (push/pull)
MB: Asus Crosshair IV Formula 890FX
SSD: OCZ Vertex 2 60 Gb
HD: 2 x WD Caviar Blue (Raid 0)
Mem: OCZ Gold series DDR3-1600
GPU: Sapphire HD 6970 in CrossfireX
PS: Corsair HX1000W Modular
Case: AZZA Solano 1000
Sniper.nkc is offline   QUOTE Thanks
Old 04-12-07, 02:45 AM   #8
Shudnawz
New Member



Join Date: Apr 2007

 
I'm having some kind of problems too, actually. I can install the program without any fuss from windows, however the programming software does not seem to recognize the n52 at all.

In my device manager, I can see the two posts that indicate that the speedpad is connected. They are marked with this yellow triangle, and as I go to the properties of each post, I get this:

"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

Thing is, I have not gotten any warning about this being a non-verified driver...crappy vista.

Last edited by Shudnawz; 04-12-07 at 02:58 AM.
Shudnawz is offline   QUOTE Thanks
Old 04-12-07, 03:06 AM   #9
Shudnawz
New Member



Join Date: Apr 2007

 
No, this really won't work. And furthermore, netgear has not released a vista-driver for my WLAN PCI card...So I have to drag a cable all across the house to get internet to the stupid thing.

Back to basics, and in this case XP.
Shudnawz is offline   QUOTE Thanks
Old 04-12-07, 05:12 PM   #10
hiddenshadows
New Member



Join Date: Apr 2007

 
Quote:
Shudnawz
I'm having some kind of problems too, actually. I can install the program without any fuss from windows, however the programming software does not seem to recognize the n52 at all.

In my device manager, I can see the two posts that indicate that the speedpad is connected. They are marked with this yellow triangle, and as I go to the properties of each post, I get this:

"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

Thing is, I have not gotten any warning about this being a non-verified driver...crappy vista.
You are almost there, there is one more thing you need to do then it will work. I had this same problem with some other drivers for my gps.

What you need to do is reboot, and as your computer is booting up keep pressing F8 to get into that windows boot selection screen, like if you wanted to start in safe mode. With vista there are more options here. You want the last option that says something about turning off the driver signing. Now once you go into windows, those yellow ! will be gone from the device manager and your nostromo profile manager should work fine.

Hope this does it for ya.
hiddenshadows is offline   QUOTE Thanks
Old 04-18-07, 11:40 PM   #11
eXphile
New Member



Join Date: Apr 2007

 
Quote:
Originally Posted by hiddenshadows
You are almost there, there is one more thing you need to do then it will work. I had this same problem with some other drivers for my gps.

What you need to do is reboot, and as your computer is booting up keep pressing F8 to get into that windows boot selection screen, like if you wanted to start in safe mode. With vista there are more options here. You want the last option that says something about turning off the driver signing. Now once you go into windows, those yellow ! will be gone from the device manager and your nostromo profile manager should work fine.

Hope this does it for ya.
You are my HERO!! This last trick actually works as I was having the same problem. I am playing WoW in Vista 64 with an n52 as I type this (dual monitors are quite cool).

Anyhow, to recap for those of you who skipped around: Do what the first poster suggests by downloading and installing the XP 64 bit driver from the Belkin site. Then you simply disable the digital driver signing via F8 (handy thing to turn off I must say) as the above post suggests and you are in n52 nirvana.

hidenshadows...you are da bomb.
eXphile is offline   QUOTE Thanks
Old 04-19-07, 06:30 AM Thread Starter   #12
Sniper.nkc
Member



Join Date: Feb 2002
Location: Palmdale CA

 
Quote:
Originally Posted by hiddenshadows
You are almost there, there is one more thing you need to do then it will work. I had this same problem with some other drivers for my gps.

What you need to do is reboot, and as your computer is booting up keep pressing F8 to get into that windows boot selection screen, like if you wanted to start in safe mode. With vista there are more options here. You want the last option that says something about turning off the driver signing. Now once you go into windows, those yellow ! will be gone from the device manager and your nostromo profile manager should work fine.

Hope this does it for ya.
Hiddenshadows, thank you for your help ! I have added the above information to post #1. Hopefully, I have captured all the neccessary steps to install the 64 bit drivers for your Nostromos N52 Speedpad.

__________________
CPU: AMD 1090T Black EditionThuban
Cooler: Corsair H50 Hydro Series (push/pull)
MB: Asus Crosshair IV Formula 890FX
SSD: OCZ Vertex 2 60 Gb
HD: 2 x WD Caviar Blue (Raid 0)
Mem: OCZ Gold series DDR3-1600
GPU: Sapphire HD 6970 in CrossfireX
PS: Corsair HX1000W Modular
Case: AZZA Solano 1000
Sniper.nkc is offline   QUOTE Thanks

Post Reply New Thread Subscribe


Overclockers Forums > Software > Microsoft Operating Systems
Microsoft Operating Systems Microsoft Operating Systems and Applications
Forum Jump

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Mobile Skin
All times are GMT -5. The time now is 10:40 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
You can add these icons by updating your profile information to include your Heatware ID, Benching Profile ID or your Folding/SETI profile ID. Edit your profile!
X

Welcome to Overclockers.com

Create your username to jump into the discussion!

New members like you have made this the best community on the Internet since 1998!


(4 digit year)

Why Join Us?

  • Share experience
  • Max out your hardware
  • Best forum members anywhere
  • Customized forum experience

Already a member?