• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED 64gb micro sd won't write or format?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

BobbyBubblehead

Member
Joined
Jan 29, 2009
I'm fighting to try and make a sandisk micro sd card that was in my phone for some years now work.

It won't write on the second dye of the memory chip I suspect at 29. Something gb free it's suddenly become unable to write or format.

I've tried to format it in the phone, pc, computer management, cmd prompt, sd formatter program and with rufus. also tried writing a new string in regedit to turn off write protect.

Currently trying to format it in cmd after being unable to delete the partition or gain access to the 16mb master boot record partition.

I can read the files on it just fine and I can delete files with file commander on Android but it won't write or format.

So if you've got anymore ideas other than grab a ticket and get in line with sandisk for a replacement...

Maybe it's just toast :shrug:

Hack now? Y/N :D
 
Last edited:

Mpegger

Member
Joined
Nov 28, 2001
Sounds like its toast. Good SD/microSD/USB/whatever memory sticks fail by locking writes to the devices. All you can do is read off of it, though it seems abit strange by your description that only part of it has been locked.
 
OP
BobbyBubblehead

BobbyBubblehead

Member
Joined
Jan 29, 2009
1.png
New Bitmap Image.png

yeah toasted... ay well a new one for six million ways to die.

alas poor sandisk... I knew him well :salute:
 

knoober

Member
Joined
Mar 18, 2015
I think its probably toast as well, but you can always try running it through diskpart > select disk # > clean all

http://mympx.org/Downloads/p13_sectionid/2/p13_fileid/13

this is a good program for testing your removable media. It has helped me spot a few fakes from china :)

Edit: I know yours isnt a fake, but the utility will still give a good idea of realiability of the card
 
OP
BobbyBubblehead

BobbyBubblehead

Member
Joined
Jan 29, 2009
well I told it to use the disk for readyboost and it wrote a 30gb file :-/

so I`m trying clean all...
which will take a while no doubt...

(Q. what did you do today bobby?
A. well I spent my day trying to format a memory card, yawn)

Gimme computer grief... :)

Edit: well in cmd it now states it's unusable and can't recover files from the mbr... So it really is over now.
 
Last edited: