• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

9600xt

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Firestrider

Member
Joined
Dec 9, 2003
Location
Orlando, FL
I just got a new video card - radeon 9600xt 128mb DDR, after I install it and start playing my games - warcraft3 and diablo2, both of the graphics are messed up! I bought this in a box from Bestbuy, is there some setting I have to change here or is my card screwed up? After I put my old card back in without installing the software to it - radeon 7000 64mb :\, the graphics were back to normal. Someone please help. I got suggestions that I should reinstall both games and run video tests for both, run both in 3D mode, put my agp/pci freq into fixed ( there is only auto and manual on my bios ), change my virtual memory, and clean my CD roms to both games. None of these seemed to work. I also ran defrag and scandisk.. still doesn't work.
 

BmanG17

Member
Joined
Dec 17, 2002
did you get the latest catalyst drivers?! I got that same card at Best Buy, but havent tried either of those games yet, I'll have to look for my CDs and try them later.
 
OP
F

Firestrider

Member
Joined
Dec 9, 2003
Location
Orlando, FL
yes I downloaded the catalyst 3.10 drivers from the ati.com website. someone said to go back a few drivers and download those because diablo 2 is kinda old. also another person said to download the omega drivers instead of catalyst 3.10 from ati.com
 
OP
F

Firestrider

Member
Joined
Dec 9, 2003
Location
Orlando, FL
How can I completely uninstall my video drivers using a driver cleaner or format. After reinstalling all the drivers download catalyst 3.7 instead?
 

Kenshiro

Member
Joined
Oct 23, 2003
first go to control panel an uninstall the video driver.

Then use the software, NASTY FILE REMOVER, or equivalent to remove the remaining files that are not removed during the uninstalling process.

reboot the computer.

then install the driver again.
 
OP
F

Firestrider

Member
Joined
Dec 9, 2003
Location
Orlando, FL
Ok, I just uninstalled all my ATI software through Add/Remove Programs, used NFR to delete 20 hidden files from ATI, restarted my computer, installed all the drivers for the the new video card, and still the graphics on diablo 2 and warcraft 3 are messed up. Should I install 3.10 catalyst drivers again or try 3.07 catalyst drivers?
 

Bulwark

Member
Joined
Dec 3, 2003
I'd try the omega drivers and if that didn't work the 3.7. Also check the blizzard site, see if anyone else has this problem, there may be a patch for it or something.