• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

AC97 and OpenGL Games

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Michfan

Member
Joined
Nov 16, 2002
Location
Alabama
This problem has never really bothered me till now. I normally use headphones when i play RTCW or Quake 3 but recently bought BF1942 and have been playing that also. It was then that i noticed something. When i have SPDIF enabled (I use a daughter PCI card to output the SPDIF from the motherboard to a digital output) the headphones will work fine for all the games but the speakers will only work for BF1942. I tested most of my other games (Simcity 4, Mafia, Splinter Cell) and the same holds true. It seems that only RTCW and Quake 3 wont output the sound through the speakers. The only way that i can get them to work is to ALT-Enter out of the game and go straight to my Volume Control Panel. Once there i uncheck and then recheck the output SPDIF box. Then i immediately click back on RTCW and the sound works. If i ALT-Enter back out of the game to do something else on my desktop it stops working. I have tried unplugging the headphones and disabling the analog port but that doesnt seem to work either. I think its something to do with the game itself. It just wont work from the startup. I am currently using Boston Acoustics BA 735's and i am wondering if anyone has had any similar problems with Quake 3 engine games or Open GL games. Any help or insight would be appreciated.
 
OP
Michfan

Michfan

Member
Joined
Nov 16, 2002
Location
Alabama
Nevermind i fixed using the newest drivers from www.realtek.com.tw. I hadnt realized they released new drivers for their chipsets last week. Odd thing is now the SPDIF Enable box is gone but it works.