• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Agh, GeForce3 won't install!!!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mac42

Member
Joined
Dec 18, 2000
Is there a way to wipe out all references to older NVidia cards in the registry? That's all I know that may fix the below problem.

For some reason i can't get my VisionTek GeForce3 to install correctly in Win2k (and yes, it's an actual retail copy of Win2k). When I first put the GF3 in it installed itself automaticly when windows started (or so I thought). After playing through a few games I noticed something was odd... after a while I figured out that there was absolutely NO hardware anti-aliasing (I didn't even have any mipmaps). I didn't notice this at first since I was running such high resolutions. I tried changing settings using both the GeForce Tweak Utility and Display Properties. The only things I could do were change the clock speed (which I had to do manually every time windows started, even though the "Apply Settings at Startup" box was checked) and change the FSAA quality (which seemed to drop my framerate while not actually anti-aliasing anything at all).

After this I uninstalled the card... it installed itself on reboot and had the same problems. After some testing I figured out it was installing the Win98 drivers...WTF? It WILL NOT accept the Win2k drivers. It says they do not contain information about my hardware. I've tried every method of installing the card, but none work. The driver version is 12.0 reference driver (came on the cd), but it wouldn't accept the 12.2 drivers either.

The only thing I can think of is that something from my old GeForce256 is messing it up in the registry. Anyone have any ideas or suggestions?


-=mac=-
 
OP
Mac42

Mac42

Member
Joined
Dec 18, 2000
Thanks for the link, but it doesn't seem to have worked. I found that I can get the drivers to install, but only by using the NT4 drivers and then "Updating the Driver".


There are 2 main problems I'm having now:

1. No mip-maps in D3D. I've tried turning them on using several different methods, but nothing seems to have worked. I've also re-installed DX8a without success (I could also try DX-Uninstaller, but I don't think the problem lies in DirectX itself).

2. Computer restart when switching to certain resolutions. I haven't tested all resolutions, but some cause the computer to restart (example: running 3DMark2001 demo at 1024x768 causes a restart, but not at 640x480, but 1152x864 worked as I remember). Any resolution that is actually successful works perfectly and stably. Again, OpenGL doesn't seem to have this problem.

I have no idea here... I'm going to send NVidia and VisionTek an e-mail as well, but I doubt I'll get a reply.


-=mac=-
 

Placid

Senior Member
Joined
Mar 13, 2001
Location
Connecticut
Is your cpu overclocked?
What type of motherboard and cpu do you have?

Also here is a link to where alot of different problems with the gf3 have been solved.
Something here might help you.

 

_jubei_

Disabled
Joined
Mar 12, 2001
Location
BROOKLYN, NY
Forget Win 2000 !!!!!!!!!!!! I read MANY posts where people with Geforce 3 and Win 2000 had many conflicts...... Check this out one guy had Win 2000 and G3 and ran 3Dmark2001 he got 1500 !!!! Yes 1500..... Then he booted win 98 or Me and he got 5000 !! ...... If you need Win 2000 do a partition and install win 98 se or ME,, and It will work for you..
 
OP
Mac42

Mac42

Member
Joined
Dec 18, 2000
I understand people have had problems with Win2k, but my experiences have been nothing but wonderful. WinME will NEVER get near mt computer again. I Tried it for 3 months... over the course of 4 serperate installs (2 of which after completely whiping and formating) that OS killed some very important graphics work and crashed every game I had (even without overclocking). Win98SE was great for stability, but doesn't let me use my most important App (Maya2.5... requires NT or MacOS). This GeForce3 thing is the ONLY problem I've ever had with Win2k... actually this problem wasn't there to begin with, it just started a few days ago. My 3DMark2001 scores are around 5500 with my TBird clocked at only 987Mhz (waterpump cracked and is getting replaced, so only air cooling at the moment).

Ok, as for the other questions: Yes, my CPU is overclocked. It's a TBird 800 @ 987 (7x141) on a K7Ta. I've had the cpu stable as high as 1190Mhz stable with watercooling. This problem exists at stock settings too. The restarting problem isn't a "stability" problem per-se, it JUST happens when switching to certain resolutions... I can run 3DMark for hours with no problems... but when i switch to certain resolutions in certain apps the computer restarts (again, only in D3D).

I'll check out those links and see what I find. Thanks for all the help... I've really never seen a problem like this before. I have 2 harddrives so I'll probably put Win98 on the older one (only ATA-33) just for gaming.


-=mac=-