• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

am i underpowered my 85W pelt??

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.
L

lightning

Guest
i just got my pelt last night and i had install it to my P3750 chip with PAL6035. i follow exactly what the instrcution to install it!! i power it up alone by using one 250W PSU, and it was rate +12V @ 10A. when i oc it to 1G, the temp was ideal at 5C but load by prime95 at 25C. after few minute run, w2k crash. somebody told me that the psu are not enough for the pelt, so i change it to 300W psu but the result still the same!! i heard that 72W pelt+PAL6035 can reach negetive temp!! but my nv reach that!! so any idea how could i make the pelt work efficiently?? :(
 

It_The_Cow

Senior Member
Joined
Apr 21, 2001
Location
Indiana
If I'm not mistaken, 85 watt TECs need about 15-16 volts to power it to the maximum extent. I have read that peltiers are most efficient at 75% of their voltage rating though
 
OP
L

lightning

Guest
if i use table fan and blow it on the hsf, the temp was drop 2-3 C!! and when i touch the alpha hsf base, it was damn hot!!! what should i do to make the temp drop even more???? :(
 

bdf24

Senior Member
Joined
Feb 15, 2001
Location
Harford, WI.
I have an 85w tec, and my temps were never that low! They were always idling around 15c, and top out around 27c. I now have water cooling and when I first start my pc it idles around 2c untill the water gets warmed up. Then after a while it idles around around 16c. But it's a hell of a lot quiter then my Alpha P3125!

I'm still trying to think of a good way of keeping the water cooler while keeping everything concealed yet. I have kids and the wife doesnt want extra stuff laying around by the computer! In other words she doesnt want it there:) Ya know what I mean!
 
OP
L

lightning

Guest
bdf24....what kind of power supply u use for ur tec?? humm.....just now i saw one post that said we can do some wiring on second psu to get higher voltage. since my psu rate the +12V @10A, can i join up the +12V and the -5V to get 17V from it?? correct me if it's impossible!! :)
 

DE

Registered
Joined
Feb 4, 2001
lightning (May 04, 2001 12:09 a.m.):
bdf24....what kind of power supply u use for ur tec?? humm.....just now i saw one post that said we can do some wiring on second psu to get higher voltage. since my psu rate the +12V @10A, can i join up the +12V and the -5V to get 17V from it?? correct me if it's impossible!! :)

You could but the problem is that the 5v- k\line can't handle much current so it wouldn't drive the pelt.