• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Anyone get Samsung's Secure Erase to work?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Thick8

Member
Joined
Apr 29, 2015
I just swapped a 500Gb 850 EVO for a 1Tb 850 EVO. I tried to make a boot-able flash drive but the process failed on 3 different fairly new flash drives. So I created the CD instead. Yet every time I try to run it I get an error message stating that the SSD drive is "frozen". So I unplug and replug in the drive yet I get the same error. I'm considering selling the drive but want it cleaned prior to doing so. Any ideas?
Thanks.
John
 

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
You don't have an unused SATA port (and power plug) you can plug the drive in that you want to secure erase? I would just plug the drive into a spare port and run Samsung diagnostics to (1) make sure the drive is OK before selling and (2) performing the secure erase.

Another alternative would be some live Linux distribution on a USB flash drive. Use 'dd' to write random data to the drive. If you can't get that working, then tackle that problem firtst.

HTH,
hank