• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Anyone still using a Voodoo 3???

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Overclocker456

Member
Joined
Feb 2, 2002
Location
New York
I'm looking for the best drivers for a Voodoo 3 card.. I have a V3 2000 PCI that I want to use.. thanks.. If you are using one what drivers are you using and how is it running your games??
 

Oni

Oni-ni-Kanab;, Ninja Hippo eater Moderator
Joined
Apr 5, 2001
Location
St. Catharines, Ontario Canada
KewlKid2000+ said:
lol SCAN VOODOO FILEZ DRIVERS!!!! they have messed up a few of my Voodoo 3 PCs

Really? I've never had a problem w/ em. A friend of mine wanted to play Quake 3 w/ his Voodoo 3, so we pulled him in some Voodoo 5 drivers. Worked like a charm.
 

Intrepid

Member
Joined
Jun 30, 2002
Location
Boise, ID, USA
I've had 2 voodoo3s and no problems here my old one was years ago when they were good. my current one i just use for dual ouptut, the windowsXP drives ther it used for the thing were great.
 

itim100

Member
Joined
Aug 17, 2002
Location
MD
Hey, I still use a Voodoo3 2000 PCI in my brother's Pentium 133. (time for you to upgrade dude)

Anyways, none of the drivers for those things ever really provided too much of an increase in anything. What is more likely to help is a tweak program. But don't OC this thing unless you know what you're doing and have non-stock cooling (the sinks were never quite enough on that Voodoo3). Using the drivers that the card came with, the non-MMX P133 can still run Half-life decently.

Look into that Voodoo3 using the Voodoo5 drivers, i've never heard of that. Turn all quality down, resolution down, and try to use OpenGL or Glide instead of Direct3D, cuz they're faster on the 3dfx cards.

Intrepid6546, i was planning on dual outputting with my old PCI V3 and an AGP MX400, but XP Pro decided it would not work (put one in and the other one would magically crap out in windows). Did you do anything special, or is my mobo just dumb?