• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

asrock 970 extreme4 can't detect transcend ssd 370 128gb

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

amd1361

New Member
Joined
Sep 8, 2014
I bought a new ssd card (Transcend 370 128gb) for my pc the other day. The problem is that when I connect it to my pc it is not detected (not shown in the bios) . For several times the system could recognize it in the bios and I tried to install windows 7,8,8.1, even linux ubuntu on it but the speed of the new ssd was too slow (took me a long time to format the drive) then suddenly it stopped and after a reboot the system failed to detect it again. When it was detected I tried all the possible settings in the bios (Ide,avchi,...)but the result was the same I also tested all the bioses available on the website from v2 to 2.6 and all sata ports . I changed the cables even I connected another power supply to my system but no success.
The ssd drive is ok because I checked it using my laptop(detected and it was so fast)

Please help me with this problem .
Thanks
 

RGone

Senior DFI Staff
Joined
Apr 20, 2004
Location
JAX, Mississauna
Make sure the SSD is connected to Sata #1 not something else. Also enable AHCI in bios. If that does not work, then you may have a bad board.
RGone...