• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

AsRock b450 steel legen no post, no beep, no display, after working properly

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
Jan 28, 2023
I have bought the b450 steel legend in combination with the AMD Ryzen 5 5600G.
Including two memory sticks of 8GB each i had the build working.
To prepare the system for windows 11 i only had to enable the secure boot.
After some reading i tried the option 'enable EUFI boot' and i was playing around with 'fast boot'.
Now, after saving the settings i rebooted the system and thats when nothing worked anymore.
The fans on my MB, and green leds do work, but nothing anymore.
After trying to enter the BIOS i figured i'd do a reset, since i expected the system to go to the state i initially received.
After reading, i did the following to reset the BIOS:
  1. Remove any cables form the computer (power, HDMI, etc)
  2. Connect the jumper switch (part 19 on the design overview)
  3. Hold the power button for 30 seconds
  4. Remove the CMOS battery
  5. Wait for 5 minutes (tried a couple of times, wating 10 minutes and 12 hours)
  6. Inserted battery
  7. Removed jumper connection
  8. Restarted system
Now after that, the system doesnt do anything, except for fans that run and lights that shine.
There is no display on screen, not over MB not over GFX.
Using a GFX card, or have none installed, no difference.
I have two 8GB RAM cards, tried in any combination over the slots, nothing
Used only one card, tried all slots, nothing. Not even with the other memory card.
I tried the debug speaker, but no sound there. After i did a faulty installation of the RAM, the 3 beeps as expected worked. There was no other signal after correctly installing the RAM.
I am out of options.
One thing i now feel bad about, is that jumping the system (resetting the bios), affected the BIOS version, so the CPU is not supported anymore? I know this is a very far stretch, but i have no clue for any other options.

How can i get out of this boot issue? Especially when everything worked fine before i tried playing with EUFI en fastboot?

Thank you so much for your help!
Unfortunately i cannot find options to do a flashback without CPU, only instant flash that requires access to the BIOS.
If you cannot access for a bios flashback, and you've cleared cmos by removing battery, then your board is toast.

RMA/Replacement time.
Hi! I'm OCF's new resident expert on Secure Boot...

The 5700G has an IGPU... therefore you should be getting an image if you connect the HDMI cable directly to the motherboard. This is what ultimately solved my own Secure Boot problem a couple of weeks ago. (I had to buy a used, but cheap, processor with IGP since mine didn't have it... but it worked.)

Doesn't sound like you've exhausted your options yet. I'd try different cables and different monitors. Always connected directly to the motherboard because there's no way you're getting anything from the graphics card after you've run into a Secure Boot issue.

Also... sadly... you don't even NEED Secure Boot for Windows 11 to run. That's a MYTH. I've been running Windows 11 for months now without it. So... tragically... all of this was for nothing.

Resetting CMOS and all that is useless because Secure Boot will remaining at its last setting no matter WHAT you do. So if Secure Boot is enabled... then it will stay enabled until you disable it. (Which I would call the ultimate design flaw...)

Different cables, different monitors, let me know how it goes.
I used different cables for the display and different monitors.
All cables work on other installations, but nothing on screen for this one on the mobo GFX.
The board was send back for RMA and was updated to the last BIOS by the vendor, but the problems persist.
Any thoughts?
So the board worked at the vendors with a BIOS update, and it won't work for you?
Do you have access to another CPU for testing?
I do not have access to another CPU for testing.
It's strange how the things work out, like.. it worked in the beginning, prepare the bios to upgrade to windows 11, and then everything fails to work?
It just doesnt make sense to me...
I was going to ask what parts did the tester use to confirm the board was working with him? Did you just send the mobo only?

What CPU, Power supply, ram, video card did the vendor use? Did the vendor mount the board on a test bench, case or did he test the board on a table?

How do you know for sure the vendor updated the bios?