• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Asrock b85m Pro3 usb3.0 header not working

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

latouffe

New Member
Joined
Mar 4, 2011
Hi Guys,

Do you know what can cause an issue with the usb 3.0 header?
I checked in the BIOS and everything is enabled.

I have a Windows 8.1 64bit and the above mobo and i tried the followings:
- Bios checked, all legacy and options enabled
- Tried to install the USB intel extensible host controller - not working
- tried to install the drivers on the cdrom for the mobo - not working
- connecting an usb2.0 hard drive - still not working

What i havent tried:
- Uninstalling all usb3.0 drivers
- juggle with the bios options

Many thanks for your help

PS: the USB3.0 found in the back are working, however the one in the front is not.
The headers overall for the usb2.0 are functioning.