• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

ASRock Z270 Supercarrier - blackscreen 09/d0, how to switch to backup BIOS?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

kartik_subbarao

New Member
Joined
Feb 22, 2017
I have an ASRock Z270 Supercarrier and used the Internet Flash utility in UEFI setup to upgrade the BIOS from 1.10 to 1.11. The upgrade process completed successfully and no errors were reported. However, when the computer rebooted with the new BIOS, it just hung with a blackscreen. I have rebooted the system over 20 times, with the same result. The boot process runs for about 15 seconds, the Dr. Debug LED settles on 09 or d0, and remains in that hung state.

According to the manual, "after several failed boot attempts, the backup BIOS will take over" -- but this doesn't seem to be happening. It still boots from the active BIOS (BIOS_A_LED is on). I also tried unplugging the computer and depressing the clear CMOS button for over 10 seconds, but that didn't seem to have any affect.

Is there any way that I can force a switch to BIOS B, or alternatively, downgrade BIOS A back to 1.10? The motherboard was working fine with 1.10 before I upgraded it to 1.11.
 

trents

Senior Member
Joined
Dec 27, 2008
Is B the stock, backup bios chip?

Have you tried jumpering the CMOS rest pins or removing the CMOS battery for about 30 minutes?
 
OP
K

kartik_subbarao

New Member
Joined
Feb 22, 2017
Good news -- I removed all but one of my RAM cards and was able to boot up with BIOS A. I attached a FAT32 USB stick with the 1.10 BIOS file and used the UEFI Instant Flash tool to successfully downgrade BIOS A. I then added back my other RAM cards and successfully booted the system just like it was before. Problem solved!
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Glad its fixed!!! The process sounds convoluted, though.

The manual should tell you how to switch to/flash the second bios. Typically it's a button or switch. Boot up on the good bios, flip the switch/button flash the borked bios... and go!
 

trents

Senior Member
Joined
Dec 27, 2008
I'm with EarthDog. The dual bios boards I have had used a switch on the motherboard to change to the other bios.