• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

ASROCK Z370 Killer SLI/ac dead?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
Nov 30, 2017

I am ready to tear my hair out. I had my computer built in the case with everything connected. I went to turn it on for the first time, and the fans spun half a turn, and then turned off. Under the ?�ASROCK??logo (cover) there was a blinking magenta light. I rechecked all connections, unplugged power supply and plugged it back in. Next time I pressed the power button, nothing spun up, but again underneath the ASROCK logo cover there was this time a greenish light that flashed once then it switched to magenta and continued flashing. When I say flashing it?�s about every couple seconds.

After this failure, I took everything out of the case and placed the motherboard on the motherboard box. I then disconnected almost everything. I only had the CPU, RAM, power supply, and cooler connected. Cables I had connected were the 24pin MB cable, the two 4pin CPU power cables, CPU fan, and the ?�HD AUDIO??header from the case. I plugged in power again, and nothing spun up, no beeps or error codes, only a blinking magenta light under the ASROCK logo cover.

At this point I did some googling and saw people with older revisions or similar models having success removing the CMOS battery or clearing CMOS. I removed the CMOS battery and disconnected power and let it be overnight (7 hrs). I cleared CMOS by moving the jumper on the 3 pin and then moved it back. This produced the same result as before ??blinking magenta light under the ASROCK logo cover.

I?�ve tried multiple RAM configurations. Leaving only one in, trying all the slots. No dice. My power supply came with a ?�tester??connecter which when connected to the MB cable, the power supply fan spins right up. Also, at one point during troubleshooting I disconnected the 8pin power cable from the PSU, and turned on power switch. The fans spun up (CPU cooler + PSU), but the PSU was clicking, and the magenta light under the ASROCK logo was flashing rapidly. I assume because it was telling me I needed to plug the 8pin power cable in. I reconnected the 8pin CPU power, and back to the old result of no activity except flashing magenta light under the ASROCK logo. I also tried shorting the header to jump the board ??didn?�t do anything.

Completely at a loss. Hoping it?�s something stupid I missed. I do suspect the motherboard is the culprit. I checked the pins and they appear to be fine. I just don?�t know why it won?�t even post or do anything except flash the magenta light. The manual does not contain any information on error codes or light flashes, and neither does the ASROCK website, so I have no idea what it means.
What CPU are you using? A Z370 motherboard will only work with 8th generation CPU such as the i3-8100, i3-8350, i5-8400, i5-8600K, i7-8700 and i7-8700K. It will not post with any older CPUs.

And if you're posting from an iPhone, please stop as all the inappropriate question marks are quite annoying.

BTW, I used that motherboard with an i3-8100 and i5-8400 with no issues.
do you have access to a different gpu by chance? just to rule your card out. try switching your gpu to a different slot also. can you get ahold of a different psu? if you can rule both of those out i would lastly give a remount a try and double check that your power switch/reset etc are connected properly. if none of those help id say the mb is shot. i feel your pain. theres nothing worse than a new rig not firing up.
I actually have taken everything out of the case. Motherboard is sitting on the box. Gpu, ram, cooler, PSU are only things connected. Along with the 24pin Mobo connector and 8pin CPU connector and fan. I have an evga g2 850w PSU that comes with a piece that will plug into the 24 pin mobo connecter. When I plugged it into that the PSU fan spins right up. When I connect the PSU back to the Mobo I get nothing except flashing magenta lights under the ASROCK logo. I suspect these aren't actually error codes based on some reading I've done.

- - - Updated - - -

Also i have plugged in my monitor via HDMI to the igpu.
I certainly would remove the CPU and check for bent socket pins.

Aghastlee, could you also create a Sig listing your system components so that they are visible with every post you make? Upper right corner. Settings. Look down left column and find Edit Signature. This is a common courtesy.

And I'm assuming these parts are all new, correct?
Sorry I only have access to an phone.
I'm using an 8700k.

That should work, and your PSU is a good one. Plus you've tried it outside of the box.

Did you try it with the GPU removed?

What specific memory are you using?