• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Asrock z97 extreme6 Dr.Debug A6 error

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

rhadwana

New Member
Joined
Sep 3, 2016
I am in the process of setting up my computer, I have all parts put together except a disc drive. Whenever I startup my computer and hit F2 to go to the BIOS the motherboard shows a code A6. How do I fix this error or get around it? I have tried updating my drivers to the latest, I have tried updating the Bios and I have tried pressing the clear cmos button on my motherboard. Nothing has worked! Also my graphics card isn't being detected so I'm wondering if it has anything to do with that. from what I can see all the right cables are plugged in and everything works perfectly except for the error I come across while entering the BIOS on startup. Any fixes for this or is it a problem with the motherboard that cannot be fixed?

My computers Specs:

i7 4790k cpu
asrock z97 extreme6 motherboard
msi 390x 8gb graphics card - (Not being detected)
16gb vengeance ram 1600mhz
1tb Seagate hardrive
750W Cit ATX power supply version 2.3
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Not an error.. normal when in the bios.

My concern is that power supply of yours... never heard of that brand before and without knowing the OEM, makes me nervous about it...


Why your gpu isn't being detected, no idea. Does any other pc find it? You have both power plugs, and the rights ones plugged into the gpu, right?
 

DaveB

Senior Member
Joined
Dec 18, 2000
A quick internet search revealed that Dr. Debug Code A6 means that the motherboard is detecting SATA devices connected to the motherboard at that time (AsRock used to define it as SCSI detect, but there's mostly only SATA on their boards these days).

From the AsRock Dr. Debug FAQ
A0 - A7 = Problem related to IDE or SATA devices. Please re-install IDE and SATA devices. If the problem still exists, please clear CMOS and try removing all SATA devices.