• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Asus Armoury Crate Not Detecting Devices for RGB?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Twisted4000

Member
Joined
Jan 12, 2013
Location
Colorado Springs, CO, USA, Earth
I've been having a lot of trouble controlling my computer's LED colors on my hardware, and I looked around online for a solution but at far nothing has worked for me. I have three RGB Cooler Master case fans, a cooler Master ARGB heatsink, two Corsair RGB RAM modules, an Asus motherboard with led's, as well as a Gigabyte graphics card with a controllable LED logo. Everything is lighting up and functioning, but Asus Armoury Crate gives me the "no available devices" error when I open it.

When I first tried it about a week ago, I was able to control the heatsink, case fans, and motherboard LED's (Armoury Crate wouldn't detect the RAM or graphics card, though I don't know if it can even do that or not). So I tried uninstalling and re-installing it (I used the Armoury Crate Uninstaller utility and CCleaner) and now it won't detect anything at all. The LED's I set the fans and motherboard to are still there (I set them to a fixed pink, while the other devices are the default rainbow), but I can't seem to control them at the moment. I tried deleting the lighting service in the registry, as I heard that could potentially fix it, but still no luck.

Any ideas on how to get this to work? I want to be able to control all the colors, including the graphics card. Thanks in advance.

Here are the specs:

Motherboard: ASUS TUF-GAMING B460-PRO WI-FI
Memory: 2x Corsair Vengeance RGB PRO 16GB DDR4
Graphics Card: GIGABYTE NVIDIA GeForce RTX 2060 SUPER
Heatsink: Cooler Master MasterAir MA620M
Case Fans: 2x Cooler Master MF120 and 1x MF140
 

BugFreak

Joined
Apr 29, 2010
Location
Central FL
With my ASUS boards some of the other brand RGB are listed as a generic "LED strip". They can be controlled by changing that devices setting Also I believe to control Corsair parts you still have to have Corsair iCUE installed so they can talk. Not sure about the Cooler Master parts though. Do they have the small 3 pin RGB plug that can go directly to the motherboard? If so plug that in. I really don't use the RGB functions that much but hopefully that will point you in the right direction.
 
OP
T

Twisted4000

Member
Joined
Jan 12, 2013
Location
Colorado Springs, CO, USA, Earth
Yes, the three fans are plugged into one of my motherboard's 4-pin RGB slots and the heatsink is in the ARGB. Idid forget to mention that I have Corsair ICUE and it's able to see the RAM, and I can control their led's with that. But still nothing with Armoury Crate.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
I mean.. it's a tough one. Are all the devices compatible with aura/asus in the first place? It *should work, but seems like you have devices from several different ecosystems trying to all play nice.

Perhaps your best bet is to ping asus and see if they can help...

Edit: sorry.. it worked before...

Did you make sure your chipset and ME drivers are installed? Latest bios, yes?
 
Last edited:

TerranBrackiatt

Member
Joined
Nov 1, 2009
i know i'm late to the party, as somehow i didn't see this thread til today.

but as an Armoury Crate user myself, i feel for you. i personally spent hours double / triple checking that everything i bought (RAM, PSU) was on the QVL list. one trouble with the software, is that every update feels like different software sometimes. it's a crapshoot wondering what features will work and which ones won't.

the biggest issues for me are whether the motherboard's OLED will recognize it's settings ( because some updates don't let me access that part of the software) and that it won't recognize that certain updates are available, like drivers for different things on the motherboard, like the X570 chipset, bluetooth drivers, BIOS updates. you know, important things that the software said it will inform me when there are updates, and make it easy for me to update. Yeah, right! Armoury Crate still shows 0201 as newest BIOS (they're up to 0801 now) 3.0.something X570 drivers (even though AMD released 4.0.3 something) etc...

It also offers updates for a few 3rd party things, like CPU-Z, but never actually shows that there's updates (CPU-Z is up to 2.01, now, but Armoury Crate shows 1.95 as the latest available... /headscratch)

As for Aura SYnc, it actually recognizes the onboard LEDs, the RAM LEDs, the fan LEDs (Halo Digital LUX addons), and the ROG NVlink (shows up as a GPU in the software). but not always. (My GPUs have no LEDs because of bad timing when i bought them: the store didn't have any.) i had to update the BIOS and X570 drivers manually, and then spend another few hours for Win11 to figure out what was going on, making several more updates for itself, and then also updating other things that all of a sudden needed updating (after the BIOS update)

I've read several places (including ASUS forums) that Armoury Crate is basically trashware because of its many problems, but unfortunately it's the only way to use aura Sync. ICUE stuff doesn't work in Aurasync, either. (i have a corsair keyboard and AIO)

and also unfortunately, once you update something through it, you probably can't downgrade it.

PS: i wish you the best of luck getting Aura Sync to work right! also, and you've probably already checked this, but it can be finicky (extra sensitive) about everything being plugged in all the way. it wouldn't recognize my ROG NVlink for several hours, and i had to reseat it several times.