• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

ASUS Maximus VIII Ranger with Samsung EVO 970 Plus

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

windygamer

Registered
Joined
Jul 28, 2016
I'm trying to upgrade a system to a larger SSD. The motherboard is ASUS Maximus Ranger VIII. The new SSD is Samsung 970 EVO Plus. During the installation of Windows 10, I get NO DRIVERS and so I went to the ASUS site and got the "Chipset" drivers.

P_setting_xxx_0_90_end_300.png

https://www.asus.com/me-en/Motherboards/MAXIMUS-VIII-RANGER/HelpDesk_Download/


IRST15.7.1.1015_RS2_20170718


And unpacked this to a USB. Then in the load driver screen of the Windows installer, it "consumed" those drivers, but still found no storage device. At this point, the only storage device is the 970 EVO Plus. So it's not seen.

So what's the issue?

The BIOS sees the device - I've confirmed that.

Is this not the correct "Drivers" to give to the Windows Installer?

I've done the following:
In BIOS checked that SATA mode AHCI is enabled. It is.
Hyperkit mode is DISABLED as per BIOS tool tip that it should be for NVMe.

Booting the Linux Mint 20 USB install stick does not see the NVMe drive either.
But as I said, the BIOS sees it as a boot option.


Thanks.
w
 

dejo

Senior Moment Senior Member
Joined
Nov 11, 2001
not familiar with that board, but you may need to enable the m.2 drivers in the uefi to make them visible. Windows 10 should see m.2 drives natively if they are enabled
 
OP
windygamer

windygamer

Registered
Joined
Jul 28, 2016
I'm not clear on your suggestion. I checked the BIOS settings and nothing looks amiss. Like I said, the BIOS sees the SSD in the Boot options. I don't see it anywhere else. I'm not clear how to "enabled the m.2 drivers in the uefi". Is this a bios setting or a windows install setting? There is a compatibility mode [CSM] in the BIOS uefi settings but it does not mention m.2.

still no joy getting this to work. Since it's working with a SATA SSD just fine, I may give up on this and use this nice 1TB SSD in some other system.
 

trents

Senior Member
Joined
Dec 27, 2008
Make sure the SSD is initialized. Even though it will show up in bios, Windows can't detect a drive that is not initialized. To check this you would need to install the drive in another working computer or attach it via a USB dock. If that computer does not see it in Windows as an installed/attached in File Managerr then the drive needs to be initialized. Use the Disk Management tool built into Windows to do this. Use the GPT partition scheme. Having said that, usually they come initialized from the factory.
 
OP
windygamer

windygamer

Registered
Joined
Jul 28, 2016
The problem is that DiskManager does not see the drive. I booted the current windows 10 system from the current SATA SSD, and ran DiskManager, and it did not see the NVME drive to Init it.

I've built systems in the past and never had a difficulty getting the Windows 10 installer on the USB stick from seeing an NVME drive fresh out of the box. Worked just fine. I'm guessing that this older Motherboard BIOS is not quite up to speed with the new NVME drive. The BIOS sees the drive - at least as far as being willing to change the boot order.

I gave up. I don't want to mess the system up. I'll just use the new NVME drive on a more modern system that I build.
 

trents

Senior Member
Joined
Dec 27, 2008
Have you tried the diskpart command from Powershell with admin privileges?

This board should recognize NVME.

- - - Auto-Merged Double Post - - -

Is your bios by any chance configured for legacy (compatibility) mode? If so, and if the Evo is using a GPT partition scheme then the drive will be invisible to the OS.
 

Attachments

  • NVME.png
    NVME.png
    35.2 KB · Views: 455