• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Asus TUF X299 Mark 2 long boot time

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
May 23, 2018
Hi, I have a pc running Windows 10 pro x64 with this setup:
_Intel Core I7 7820X processor
_Gigabyte GeForce GTX 1070 G1
_Corsair Vengeance LPX 64GB ram 2.700 Mhz (4 modules of 16GB)
_2 Samsung 960 PRO NVMe M.2 512GB
_1 HD WD Blue 3TB
_Corsair 650 W power supply
_ Asus TUF X299 Mark 2

Memory modules are setup like this:
And in the boot menu al drives are disabled but the main with the OS.
The question is that the boot time is very long, because once the start button is pressed the screen remains black for at least 15 seconds until the Asus logo appears, and after that it still takes additional time until Windows is available.
This happens when the computer is started after powered it off, and also when it is hibernating or sleeping. In any case, the time, in my opinion is excessive, especially if I compare it with other computers that I own, with a much older hardware, which do this much faster and in the case of sleep mode and the hibernation, they come out almost instantaneously. I already disabled the memory check in the bios and activated the fast start, but without result. I do not understand what the problem may be.
Thanks in advance.


Mar 7, 2008
Mine seems slower since I changed from 16GB of ram to 64GB so I wonder if that is part of it. I never timed it though. You can also try disabling CSM if you don't need it for legacy support. I rarely turn systems on/off so I haven't paid close attention to this.


Benching Team Leader
Jan 2, 2005
Maybe there is additional memory training or memory test during boot enabled. Also RAID or already mentioned legacy mode for some devices are slowing down boot time.


New Member
May 23, 2018
Regarding to CSM, I get this warning when choose disable:

And for the memory training the setup is the same as posted in this thread:

I don't know if it could be improved, but when I changed this memory setup, the boot time was reduced because before that there was bigger than now.

- - - Updated - - -

Don't know what should I do regarding to that warning. I choose the automatic option instead of the disabled, but nothing changed in the boot time.


May 7, 2005
i would just pull two of the 4 memory modules. if your boot time improves you know where to start looking. if it doesnt improve, your going to have to continue the troubleshooting. id bet its something really simple that your just overlooking.