• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

ati radeon 9800 pro question.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

gibz117

Member
Joined
Apr 11, 2009
Location
gary, in
does anyone here have an ati radeon 9800 pro agp 128mb vid card. i have one that a friend gave to me that is missing two capacitors. im trying to find the numbers on them so i can try to find some replacements. im looking for the two black caps towards the top of the card.

its the black things in the box. if anyone can tell me the numbers on them, thanks in advance.
 

Attachments

  • vid card.jpg
    vid card.jpg
    38.8 KB · Views: 128

Old Thrashbarg

Member
Joined
Sep 26, 2007
Those aren't caps... they're inductors. I found a better picture of the card, seems to be 2.2uH, 13A parts. (SMD, unshielded, drum type.)

These would probably work as replacements, although I'm not sure how critical the tolerances and such are, and the spec sheet on the original parts is a bit light on such information.

But before replacing the things, I'd be taking a careful look at why they're missing. That's not the sort of thing that would normally blow up or fall off. Actually, it could even be that they were never there to begin with, due to cost-cutting or whatever... have you tested the card to see if it works?
 
OP
gibz117

gibz117

Member
Joined
Apr 11, 2009
Location
gary, in
the inductors definatly came off at some point. i have tested the card, and it didnt even power on. the guy i got it from said it was working, and when he removed it to upgrade, they came off.