• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED [Biostar TA790GX A3+] - Failed Bios updates

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

BoundByBlood

Maybe Something Cool?
Joined
Sep 27, 2009
Location
MS Gulf Coast
Specs:
Biostar TA790GX A3+
AMD Phenom II X2 550 BE
4GB PC3 [email protected]
Windows 7 Ultimate x64

I have been having the most unusual problem with my motherboard which has been effectively preventing me from flashing my bios. I've gone through three bios chips and if this keeps up I'm going to go bald from pulling my hair out. So here's a rundown of what has happened.

I bought my CPU with the intention of unlocking the quad. When I got my motherboard for the first time I had to use the F12 ez-flasher to flash it with a mod bios on my flash drive I got off of a forum to give me the ACC function. After enabling the ACC I also had to set the HT link width to 1.6GHz (as recommended by the end user distributing the mod bios) to prevent unexpected results. Bada bing bada boom it worked and I now had a Phenom II X4 B50. This was the first and only time I was able to successfully unlock the quad.

Everything was going fine for a while except for some stability issues. At random intervals the CPU would revert back to being a dual core. I still haven't figured out if this was a windows or a bios issue, although my money is on the bios. One day I completely lost the ACC so I restarted the computer, hit F12 and proceeded to flash the bios again. The write procedure was fine and didn't encounter any errors. I restarted the computer and...nothing. I didn't get the bios boot load screen, not post, absolutely nothing. Computer was dead in the water. I contacted newegg and they sent me a new board.

I was using the dual core for a couple of days when I decided I wanted the quad again. So I restarted the computer, went into bios to load the optimized defaults, hit F12 and proceeded to flash it again. The second time around was pretty much the same as in the first where I didn't encounter any errors in the write proceedure. After the flashing the computer restarted and the same thing happened. Dead in the water AGAIN. This time I opted to call Biostar and had a conversation with a really cool tech. He told me it was pretty much a failed update (although he couldn't give a reason why the updates were failing) and I just needed a new bios chip. I went ahead and ordered a new bios chip off of Biostar. The tech also informed me that if I wanted the ACC that there is a forum (rebelshavenforum.com) that has Biostar engineered bios files with the function embedded in them. Biostar used to make bios with the ACC until AMD told them they couldn't do it anymore so Biostar then distributed their old bios to the forum. He recommended I use those bios if I want to unlock the quad.

I got the new chip in and I decided to press my luck in unlocking the quad for a third time. I went through the flashing routine yet again and needless to say it failed forcing me to order another bios chip. Like a chimp whom hasn't learned from his mistakes after being shocked with an electrical current twice, I decided to try to unlock the quad a third time with my second replacement bios chip. You guessed it - it failed. What has been bugging the crap out of me is that the write proceedures aren't encountering errors so for the life of me I can't figure out why I was able to successfully do it the first time yet fail every other time.

The only common denominator in this unusual equation I can come up with is the DMI date. If memory serves me well I didn't erase the DMI date the first time when prompted by the F12 flash utility which could be why it worked the first time. The other three times I may have prompted to erase the DMI date, but I'm not 100% on this. My memory can be shoddy so it's unclear if my memories are true or if I'm remembering the way it happened falsely if only because I want to believe that is the way it happened for no other reason than to justify what is going on with the motherboard.

Can someone help or does anyone have any ideas?
 
Last edited:

trents

Senior Member
Joined
Dec 27, 2008
I guess the question that immediately comes to mind is have you considered it may have not been smart to use a moded bios, even one that was recommended (unofficially, it sounds like) by a Gigabyte tech? Do I understand you to say that Gigabyte no longer puts the ACC function in any of their bioses? That doesn't sound correct. I wonder if folks who have made recent Gigabyte board purchases with the 710 SB and up chip could confirm this. I don't think that's what I'm hearing from other forum users buying new Gigabyte boards or from NewEgg customers. Can anyone else comment on this?
 
Last edited: