• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

BIZARRE! Under resource monitor, my drive C is being read as drive H!

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

blackjackel

Member
Joined
Oct 18, 2002
Location
Los Angeles
Today I opened up my resource monitor and couldn't see a single file operation on my drive C:... odd, windows 10 is on drive C...

I then notice a ton of reads from drive H, but not normally, like this: H:0\System Volume Information\blahblah... or H:0\windows\ notice the 0 in between the : and \

So that's strange but then I realized something... there's no \windows\ folder on my drive H... wtf?

Windows thinks my C drive is my H drive, what in the hell is going on?
 
OP
blackjackel

blackjackel

Member
Joined
Oct 18, 2002
Location
Los Angeles
here you go, some things were blocked out for privacy/paranoia reasons.
Notice the H:0\ drive has windows on it, everything on the H:0\ is actually the C: drive...

drives.png wtf.png
 

RJARRRPCGP

Member
Joined
May 30, 2004
Today I opened up my resource monitor and couldn't see a single file operation on my drive C:... odd, windows 10 is on drive C...

I then notice a ton of reads from drive H, but not normally, like this: H:0\System Volume Information\blahblah... or H:0\windows\ notice the 0 in between the : and \

So that's strange but then I realized something... there's no \windows\ folder on my drive H... wtf?

Windows thinks my C drive is my H drive, what in the hell is going on?

You're gonna have a lot of file backing up to do and then you must wipe the drives with the existing Windows OSes and then before doing a reinstall of Windows, you must unplug all other drives that are not for the OS!

(And with XP, you also were required to disconnect the card reader!)
 
OP
blackjackel

blackjackel

Member
Joined
Oct 18, 2002
Location
Los Angeles
You're gonna have a lot of file backing up to do and then you must wipe the drives with the existing Windows OSes and then before doing a reinstall of Windows, you must unplug all other drives that are not for the OS!

(And with XP, you also were required to disconnect the card reader!)

Why would I do that? I'm having absolutely no problems with windows, everything seems to work fine, the only issue is that drive C: displays as H:0\ I figure it's a setting or something silly that i can alter.
 

c627627

c(n*199780) Senior Member
Joined
Feb 18, 2002
I am not a 100% on what is going on here but as a result of a botched drive image a long time ago, I had my Windows OS change drive letters.
I had big problems though until I reverted back to the old drive letter.

Now I like to install Windows on custom drive letters so my Windows is not always on C:

But here is how I fixed it and this may not apply to you and I would not mess with this if you have no problems.




Change the System/Boot Drive Letter


At boot and before you see the Start Menu / Task Bar, you may see the following error message:
rundll32.exe
Windows cannot access specified device path or file. You may not have the appropriate permissions to access this item.

CTRL + ALT +DEL > Start Task Manager > Application TAB > New Task... > explorer.exe > OK

Change the OS drive letter, for example, from G: to V:
Start Menu > regedit.exe > HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices >

1. First rename \DosDevices\V: to \DosDevices\Z: (to free it up)
2. Now you can rename \DosDevices\G: to \DosDevices\V:

Drive letter G will become drive letter V upon reboot.


In case of problems, instructions to change drive letter G: to V:

01. Make a full system backup of the computer and system state.
02. Log on as an Administrator.
03. Start Regedt32.exe.
04. Go to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
05. Click on MountedDevices.
06. Right click on MountedDevices> Permissions
07. Verify that Administrators have full control. Change this back when you are finished with these steps.
08. Exit Regedt32.exe, and then start Regedit.exe.
09. Locate the same registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
10. To free up drive letter V: On the right pane, right click on \DosDevices\V: > Rename > \DosDevices\Z:

Note: Must use Regedit instead of Regedt32 to rename this registry key.

11. Right-click \DosDevices\G: > Rename > \DosDevices\V:

12. Exit Regedit, and then start Regedt32.
13. Change the permissions back to the previous setting for Administrators.
13. Restart the computer.