• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Buggy Gigabyte X370 K7 MoBo

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Lamprongulos

Registered
Joined
Apr 18, 2017
Ok so yesterday I start to try and O/C my CPU and Ram(1700X and Dominator 2X16 @3200) Tried 3.8 @1.375 and ram XMP @ 2933 it wasn't stable so go back into bios and now it won't allow me to make any changes in ADV Settings and it is back to STOCK.I am using F3 bios could it be corrupt?? Do i roll back to F2 and then re flash to F3 ?? If So How? Any and all help is welcome.
Thanks in advance:):):):)


P.S. OH THE JOY JOY OF A BUGGY NEW PLATFORM LMAO
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
I would try clearing the CMOS first. Then when you overclock leave the memory out of the equation until you have the CPU somewhat stable. Most likely that memory is the problem right now. This platform is very picky at present. Even people with 2x8 sticks (single rank) are having issues with higher speeds yours is dual rank which is harder to stabilize. You may end up running it at 2666 until the next AGESA update which is supposed to help with memory compatibility. If you find it's still giving you problems you should be able to re-flash the same BIOS from within BIOS using the boards built in utility.
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
Both I have found this platform a bit more difficult to clear than any other