• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED Can't connect to work server: Could not get an assignment

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

gabi_golan

Member
Joined
Dec 15, 2011
Got an error today, saying "Could not get an assignment". Got back home and seen that [email protected] doesn't get any new WU's. Nothing was changed in the client, and it worked fine for months before.
What can be done?
The log says:
Code:
*********************** Log Started 2014-03-18T19:22:19Z ***********************
19:22:19:************************* [email protected] Client *************************
19:22:19:      Website: http://folding.stanford.edu/
19:22:19:    Copyright: (c) 2009-2013 Stanford University
19:22:19:       Author: Joseph Coffland <[email protected]>
19:22:19:         Args: 
19:22:19:       Config: C:/Program Files/FAHClient/config.xml
19:22:19:******************************** Build ********************************
19:22:19:      Version: 7.3.6
19:22:19:         Date: Feb 18 2013
19:22:19:         Time: 15:25:17
19:22:19:      SVN Rev: 3923
19:22:19:       Branch: fah/trunk/client
19:22:19:     Compiler: Intel(R) C++ MSVC 1500 mode 1200
19:22:19:      Options: /TP /nologo /EHa /Qdiag-disable:4297,4103,1786,279 /Ox -arch:SSE
19:22:19:               /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2 /Qopenmp /Qrestrict /MT /Qmkl
19:22:19:     Platform: win32 XP
19:22:19:         Bits: 32
19:22:19:         Mode: Release
19:22:19:******************************* System ********************************
19:22:19:          CPU: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
19:22:19:       CPU ID: GenuineIntel Family 6 Model 26 Stepping 4
19:22:19:         CPUs: 8
19:22:19:       Memory: 6.00GiB
19:22:19:  Free Memory: 2.22GiB
19:22:19:      Threads: WINDOWS_THREADS
19:22:19:  Has Battery: false
19:22:19:   On Battery: false
19:22:19:   UTC offset: 2
19:22:19:          PID: 4980
19:22:19:          CWD: C:/Program Files/FAHClient
19:22:19:           OS: Windows 7 Ultimate
19:22:19:      OS Arch: AMD64
19:22:19:         GPUs: 1
19:22:19:        GPU 0: ATI:5 Tahiti XT [Radeon HD 7970]
19:22:19:         CUDA: Not detected
19:22:19:Win32 Service: false
19:22:19:***********************************************************************
19:22:19:<config>
19:22:19:  <service-description v='[email protected] Client'/>
19:22:19:  <service-restart v='true'/>
19:22:19:  <service-restart-delay v='5000'/>
19:22:19:
19:22:19:  <!-- Client Control -->
19:22:19:  <client-threads v='4'/>
19:22:19:  <cycle-rate v='4'/>
19:22:19:  <cycles v='-1'/>
19:22:19:  <data-directory v='.'/>
19:22:19:  <disable-sleep-when-active v='true'/>
19:22:19:  <exec-directory v='C:\Program Files\FAHClient'/>
19:22:19:  <exit-when-done v='false'/>
19:22:19:  <fold-anon v='false'/>
19:22:19:  <open-web-control v='false'/>
19:22:19:
19:22:19:  <!-- Configuration -->
19:22:19:  <config-rotate v='true'/>
19:22:19:  <config-rotate-dir v='configs'/>
19:22:19:  <config-rotate-max v='16'/>
19:22:19:
19:22:19:  <!-- Debugging -->
19:22:19:  <assignment-servers>
19:22:19:    assign3.stanford.edu:8080 assign4.stanford.edu:80
19:22:19:  </assignment-servers>
19:22:19:  <capture-directory v='capture'/>
19:22:19:  <capture-on-error v='false'/>
19:22:19:  <capture-packets v='false'/>
19:22:19:  <capture-requests v='false'/>
19:22:19:  <capture-responses v='false'/>
19:22:19:  <capture-sockets v='false'/>
19:22:19:  <debug-sockets v='false'/>
19:22:19:  <exception-locations v='true'/>
19:22:19:  <gpu-assignment-servers>
19:22:19:    assign-GPU.stanford.edu:80 assign-GPU.stanford.edu:8080
19:22:19:  </gpu-assignment-servers>
19:22:19:  <stack-traces v='false'/>
19:22:19:
19:22:19:  <!-- Error Handling -->
19:22:19:  <max-slot-errors v='5'/>
19:22:19:  <max-unit-errors v='5'/>
19:22:19:
19:22:19:  <!-- Folding Core -->
19:22:19:  <checkpoint v='10'/>
19:22:19:  <core-dir v='cores'/>
19:22:19:  <core-priority v='low'/>
19:22:19:  <cpu-affinity v='false'/>
19:22:19:  <cpu-usage v='100'/>
19:22:19:  <gpu-usage v='100'/>
19:22:19:  <no-assembly v='false'/>
19:22:19:
19:22:19:  <!-- Folding Slot Configuration -->
19:22:19:  <cause v='ANY'/>
19:22:19:  <client-subtype v='STDCLI'/>
19:22:19:  <client-type v='normal'/>
19:22:19:  <cpu-species v='X86_PENTIUM_II'/>
19:22:19:  <cpu-type v='AMD64'/>
19:22:19:  <cpus v='-1'/>
19:22:19:  <cuda-index v='0'/>
19:22:19:  <gpu v='true'/>
19:22:19:  <max-packet-size v='normal'/>
19:22:19:  <opencl-index v='0'/>
19:22:19:  <os-species v='UNKNOWN'/>
19:22:19:  <os-type v='WIN32'/>
19:22:19:  <power v='full'/>
19:22:19:  <project-key v='0'/>
19:22:19:  <smp v='true'/>
19:22:19:
19:22:19:  <!-- HTTP Server -->
19:22:19:  <allow v='127.0.0.1'/>
19:22:19:  <connection-timeout v='60'/>
19:22:19:  <deny v='0/0'/>
19:22:19:  <http-addresses v='0:7396'/>
19:22:19:  <https-addresses v=''/>
19:22:19:  <max-connect-time v='900'/>
19:22:19:  <max-connections v='800'/>
19:22:19:  <max-request-length v='52428800'/>
19:22:19:  <min-connect-time v='300'/>
19:22:19:  <threads v='8'/>
19:22:19:
19:22:19:  <!-- Logging -->
19:22:19:  <log v='log.txt'/>
19:22:19:  <log-color v='false'/>
19:22:19:  <log-crlf v='true'/>
19:22:19:  <log-date v='false'/>
19:22:19:  <log-date-periodically v='21600'/>
19:22:19:  <log-debug v='true'/>
19:22:19:  <log-domain v='false'/>
19:22:19:  <log-header v='true'/>
19:22:19:  <log-level v='true'/>
19:22:19:  <log-no-info-header v='true'/>
19:22:19:  <log-redirect v='false'/>
19:22:19:  <log-rotate v='true'/>
19:22:19:  <log-rotate-dir v='logs'/>
19:22:19:  <log-rotate-max v='16'/>
19:22:19:  <log-short-level v='false'/>
19:22:19:  <log-simple-domains v='true'/>
19:22:19:  <log-thread-id v='false'/>
19:22:19:  <log-thread-prefix v='true'/>
19:22:19:  <log-time v='true'/>
19:22:19:  <log-to-screen v='true'/>
19:22:19:  <log-truncate v='false'/>
19:22:19:  <verbosity v='5'/>
19:22:19:
19:22:19:  <!-- Network -->
19:22:19:  <proxy v=':8080'/>
19:22:19:  <proxy-enable v='false'/>
19:22:19:  <proxy-pass v=''/>
19:22:19:  <proxy-user v=''/>
19:22:19:
19:22:19:  <!-- Process Control -->
19:22:19:  <child v='false'/>
19:22:19:  <daemon v='false'/>
19:22:19:  <pid v='false'/>
19:22:19:  <pid-file v='[email protected] Client.pid'/>
19:22:19:  <respawn v='false'/>
19:22:19:  <service v='false'/>
19:22:19:
19:22:19:  <!-- Remote Command Server -->
19:22:19:  <command-address v='0.0.0.0'/>
19:22:19:  <command-allow-no-pass v='127.0.0.1'/>
19:22:19:  <command-deny-no-pass v='0/0'/>
19:22:19:  <command-port v='36330'/>
19:22:19:
19:22:19:  <!-- Slot Control -->
19:22:19:  <idle v='false'/>
19:22:19:  <max-shutdown-wait v='60'/>
19:22:19:  <pause-on-battery v='false'/>
19:22:19:  <pause-on-start v='false'/>
19:22:19:
19:22:19:  <!-- User Information -->
19:22:19:  <machine-id v='0'/>
19:22:19:  <passkey v='********************************'/>
19:22:19:  <team v='32'/>
19:22:19:  <user v='gabi_golan'/>
19:22:19:
19:22:19:  <!-- Web Server -->
19:22:19:  <session-timeout v='3600'/>
19:22:19:  <web-allow v='127.0.0.1'/>
19:22:19:  <web-deny v='0/0'/>
19:22:19:
19:22:19:  <!-- Work Unit Control -->
19:22:19:  <dump-after-deadline v='true'/>
19:22:19:  <max-queue v='16'/>
19:22:19:  <max-units v='0'/>
19:22:19:  <next-unit-percentage v='99'/>
19:22:19:
19:22:19:  <!-- Folding Slots -->
19:22:19:  <slot id='0' type='GPU'>
19:22:19:    <client-type v='beta'/>
19:22:19:    <next-unit-percentage v='98'/>
19:22:19:  </slot>
19:22:19:</config>
19:22:20:Connecting to assign-GPU.stanford.edu:80
19:22:21:Connecting to assign-GPU.stanford.edu:8080
19:22:22:Read GPUs.txt
19:22:22:Trying to access database...
19:22:22:Successfully acquired database lock
19:22:22:Enabled folding slot 00: READY gpu:0:Tahiti XT [Radeon HD 7970]
19:22:22:Started thread 4 on PID 4980
19:22:22:Started thread 5 on PID 4980
19:22:22:Started thread 6 on PID 4980
19:22:22:Started thread 7 on PID 4980
19:22:22:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
19:22:23:WU00:FS00:News: Welcome to [email protected]
19:22:23:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
19:22:23:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
19:22:24:WU00:FS00:News: Welcome to [email protected]
19:22:24:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
19:22:24:ERROR:WU00:FS00:Exception: Could not get an assignment
19:22:25:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
19:22:25:WU00:FS00:News: Welcome to [email protected]
19:22:25:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
19:22:25:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
19:22:27:Started thread 8 on PID 4980
19:22:30:WU00:FS00:News: Welcome to [email protected]
19:22:30:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
19:22:30:ERROR:WU00:FS00:Exception: Could not get an assignment
19:23:25:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
19:23:25:WU00:FS00:News: Welcome to [email protected]
19:23:25:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
19:23:25:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
19:23:26:WU00:FS00:News: Welcome to [email protected]
19:23:26:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
19:23:26:ERROR:WU00:FS00:Exception: Could not get an assignment
19:25:02:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
19:25:03:WU00:FS00:News: Welcome to [email protected]
19:25:03:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
19:25:03:WU00:FS00:Connecting to assign-GPU.stanford.edu:8080
19:25:04:WU00:FS00:News: Welcome to [email protected]
19:25:04:WARNING:WU00:FS00:Failed to get assignment from 'assign-GPU.stanford.edu:8080': Empty work server assignment
19:25:04:ERROR:WU00:FS00:Exception: Could not get an assignment
19:27:39:WU00:FS00:Connecting to assign-GPU.stanford.edu:80
 
OP
gabi_golan

gabi_golan

Member
Joined
Dec 15, 2011
Update: got some WU after 2 client restarts, so maybe it'll be ok.
If we solved all their GPU WU's that's a thing to be proud of 8>]
 

'Cuda340

Very Welcoming Senior, Premium Member #11
Joined
May 30, 2004
Location
[email protected]
Working to fix the shortage of GPU WUs

.
March 18, 2014 by Vijay Pande ·

We’ve had a large influx of GPU clients, including a big donation of time from a corporate partner, and we’ve run a bit low on GPUs late last night (pacific time). The team got new WUs going last night and we expect they should be online shortly.

While this shortage is naturally annoying for donors (hopefully just briefly annoying, with the new WUs coming online soon), there is an interesting upside to this––we’ve been really blown away with all the GPU resources donors have been running and look forward to the exciting research we can accomplish with this great outpouring of support.
 

orion456

Member
Joined
May 31, 2004
WHY do I feel I was expecting them to add.....

consequently we are reducing GPU points....

maybe that will come tomorrow.

Funny, I would have thought that all the new gaming consoles out recently would result in less GPUs available.
 
Last edited: