• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

chkdsk running automatically

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Terrorsmurf

Registered
Joined
Aug 13, 2003
i'm on a raid-0 setup w/ 2 120gig Seagate 7200.7 SATA drives. anyhow chkdsk runs everytime I restart on only one of my partitions only. is there a way to turn it off b/c I cannot defragment if I wanted to b/c of this. i'm running XP as well
 

mdcomp

Classic Administrator
Joined
Nov 23, 2001
Try going into Start|Run|msconfig.
Once there go into the startup tab and look for chkdsk or /chkdsk if its there uncheck it. If not let me know and I will try and figure out something else. Good luck!

Matt
 

redduc900

Inactive Moderator
Joined
Dec 17, 2000
Location
Portland, OR
You might also want to give this a try...under the following Key in the Registry (Start | Run | Type regedit and click OK), make sure the "BootExecute" Value Name has a Value Data of...autocheck autochk*

HKEY_LOCAL_MACHINE | SYSTEM | CurrentControlSet | Control | Session Manager

The binary "Value Name" in the RH pane will be "BootExecute" (without the quotes). Right-click the "BootExecute" binary name and select "Modify" (if the value is something other than autocheck autochk*). Type in the correct value as I've shown it below. Under the "Value" column, it should look like this...

autocheck autochk*...You'll need to reboot for the change to take effect. ;)
 
Last edited:
OP
T

Terrorsmurf

Registered
Joined
Aug 13, 2003
hmm msconfig shows nothing on startup that automatically starts chkdsk. the boot execute value in regedit also is fine with a value of autocheck autochk*. It only happens to one of my partitions and it doesn't look like the same chkdsk when i actually schedule it. Only 3 steps instead of 5.

one of your disks needs to be checked for consistancy.
 

redduc900

Inactive Moderator
Joined
Dec 17, 2000
Location
Portland, OR
Check the following Registry Keys...

HKEY_LOCAL_MACHINE | SOFTWARE | Microsoft | Windows NT | CurrentVersion | Winlogon

Add or modify the following Value name...
SFCScan=DWORD Value data of 0

HKEY_LOCAL_MACHINE | SYSTEM | CurrentControlSet | Control | Session Manager

Add or modify the following Value name...
AutoChkTimeOut=DWORD Value data of 0

The following MSKB article may also apply to your situation...

Chkdsk Runs Each Time That You Start Your Computer
 

redduc900

Inactive Moderator
Joined
Dec 17, 2000
Location
Portland, OR
Are you sure you're not referring to the DWORD Value names "not existing" in the RH pane, instead of the actual Keys? If the DWORD's aren't listed, then you'll need to create them. Right click in the RH pane of each of the above Keys and select New-->DWORD Value | Type in the Value names according to the specific Keys above | Right cick each Value name and select "Modify" | In the "Edit DWORD Value" window that opens, check to make sure 0 is shown in the Value data field, with the Hexadecimal radio button selected.
 
OP
T

Terrorsmurf

Registered
Joined
Aug 13, 2003
just added the registry dword values up above, restarted and it still runs chkdsk. I go into dos prompt and try to disable it through

chkntfs d:

and it tells me the drive is dirty. any other ideas? should i just reinstall xp?
 

redduc900

Inactive Moderator
Joined
Dec 17, 2000
Location
Portland, OR
From a command prompt (Start | Run | Type cmd and click OK), type chkntfs /D and then reboot...a chkdsk should run, but not again on the following boot. You can see what the /D switch does by typing chkntfs /? at the prompt. :)
 
Last edited:

shadowdr

Senior Member
Joined
Jan 10, 2001
If chkdsk runs there is a reason for it.Win will run chkdsk at boot if there is a problem with any of your drives.First thing to do is back up your other drives.corrupted data has been written to your drive or partition,it may be a corrupt file or a bad spot on one of your disc's.You should then run the option for repair from the startup cd.With win 2000 it is chkdsk /p but like redduc says chkdsk /? will tell you the options.After completeing this look at the report onscreen if it reports kb's in bad sectors then you have a bad spot.If it is reparable then chkdsk will do it but thats not what it sounds like is happening.You can then run the drives utilities to see if they can make a repair.if not you will end up doing a low level format and reinstalling windows or the backups.
In my case, I had to do a low level and installing backups only to find it was a corrupted file that had damaged the disc.