• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

com surrogate useing cpu

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

caddi daddi

Godzilla to ant hills
Joined
Jan 10, 2012
On my win10 machine I have A process called com surrogate using A bit of my cpu driving my temps up.
I have moved to A place that is very hot and humid and my temps now reach into the upper 90's under A moderate load @4.3 ghz/1.26vcore, the mid 80's is about the norm for this cpu back here in the states.
Can I delete this process from windows.
when I kill the process in task manager it simply restarts.
cpu, intel 9900K
cooling, big water, phobya 5x120 80mm thick + mora, 4x180 cooling cpu and 2 titan x pascals.
Any help I can get will be nice.
 

bmwbaxter

Joined
Jun 9, 2010
Dont think it is something you can remove. It shouldn't be using much CPU. Quick google search will turn up some info on it, but nothing indicated it uses many resources.

EDIT: might be a virus pretending to be com surrogate?
 
OP
caddi daddi

caddi daddi

Godzilla to ant hills
Joined
Jan 10, 2012
It uses about 20-25% cpu on that machine when at idle.
I have booted to safe mode and ran three scanners and found zero issues on the machine then the hurricane hit and the power died and we returned here so I can't do more till we go back.
I have found A few things on the web about it I will try, at that time I'm just trying to load up on info now as internet access there is horrid at best and most often unavailable.
 
OP
caddi daddi

caddi daddi

Godzilla to ant hills
Joined
Jan 10, 2012
I have found the sfc /scannow command, I'll try that, it very well might be A little corruption.

I have 2 1Tb nvme drives in it and 2 sata ssd's.