• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Computer wont turn on?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

bohansen

Member
Joined
Dec 27, 2004
hey i got a problem with my computer, I went to restart it and it shut off but it wouldnt turn back on, when I press the power button on my case nothing happens.

I dont know if its a PSU problem?
I have a asus p5b delux mobo and the little asus light up icon thing on the button is flashing, it usually stays constant.

I unplugged the PSU a bunch and tried but its not helping, I also took out the battery on the motherboard and put it back in hoping that might do something but nothing.

Anyone got any ideas?
 

Bobnova

Senior Member
Joined
May 10, 2009
If you still have the manual, look it up in there.
If not, unplug the PSU, push the power button, then take the battery out of the motherboard and put it back in upside down. Then put it back in right side up, plug the PSU back in, and hit the power button. Then hope it works.
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
thanks for the fast response! i'll try that out, and i dont think i have the manual anymore.. been like 3 years or something since ib uilt this rig
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Just tried that out and nothing happened. still the same response from my system.
 

OnDborder

Senior Member
Joined
May 6, 2001
Location
HOT 'n Arizona
Oh boy...
A matter of deduction now.
3yrs..?
To start off with, I would eliminate the switch being the fault by jumping the 2 pins that the power switch is connected to.
If that's not it. Pull the board/cpu/1 stick of ram/vcard/psu out of the case, put it on a non-conductive surface, and try to start it up.
 

Bobnova

Senior Member
Joined
May 10, 2009
I think i'd hit the PSU next, do you have a multimeter? If not go get one from harbor freight, costs $7 or so.
Then you can unplug the PSU from everything but the wall, jumper two pins on the main mobo connector to turn it on (forget which two), and start checking voltages.
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
oh man >_< sounds like alot of hassle. I think i'm just gonna run to Best Buy or somewhere and pick up a PSU and try that, then return it afterwards if it works/doesn't work.

This might be the excuse I need to upgrade.. when i get the money
 

vgta88

Member
Joined
Nov 15, 2007
I think i'd hit the PSU next, do you have a multimeter? If not go get one from harbor freight, costs $7 or so.
Then you can unplug the PSU from everything but the wall, jumper two pins on the main mobo connector to turn it on (forget which two), and start checking voltages.

--With the tab, notch facing up to the sky. It is pin 14 on a 20 pin psu to any ground(black wires). (pin 14 is green)(count 1-10 buttom row, left to right, 11 to 20 on the top row with the notch)

For 24 pin power supplies it's pin 16, connect that to any ground. Count 1-12 bottom row, 12 to 24 top row.

useful to look at this. http://en.wikipedia.org/wiki/ATX#Power_supply

--I had a similar problem and it turned out to be the motherboard because the power turned on just fine and powered a different machine. I tested ram, cpu, and fan. The south bridge gets hot and the motherboard light stays on but thats it. I should probably make a thread about it. When things get hot it might be a short circuit but theres nothing on the southbridge itself that I can see shorting it out. That might help ya and do test the power switch on your case by jumping the pins on the motherboard like OnDborder suggested to rule it out. I actually took my switch faceplate off and tested it but its faster to rule it out by jumping the motherboard pins.
 
Last edited:
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Is there a guide for jump starting all these things? i'v never done anything like that before and I dont wanna damage things any further.
 

OnDborder

Senior Member
Joined
May 6, 2001
Location
HOT 'n Arizona
Do you know where your power switch wires connect to your motherboard?
Get a small screwdriver and simply connect the two pins where the wire connects(jump).
Personally, I'd do this first.
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Thanks, i'll try that when I get home (using my univ. library computers for now)

Hopefully that will help.

Just to be clear, your talking about those set of pins on the bottum of the mobo that have things such as HDD led and Power on and whatnot right?
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Well, I tried jumping the starter pins with nothing happening.

The thing i'm worrying about is the Asus led at the bottom of the motherboard, it usually stays on constant blue, but it now flickers at a constant rate, when I unplug the PSU the flickering slows down till it stops, then when I plug the PSU back in it flickers again.
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Well I went to BB and picked up the cheapest PSU I could find and gave that a shot, everything booted up fine when I plugged in just the mobo, so i'm gonna go and return that one and pick one up online. I'm pretty sure that I currently have a 550w right now, gonna pick up a heftier one maybe around 700w or so.

Gonna do a few more tests by plugging in each component one at a time and checking if it boots, but i'm pretty confident that its my PSU thats the problem.
 

Bobnova

Senior Member
Joined
May 10, 2009
That is very good news, if the PSU didn't roast the mobo it probably didn't roast anything else, either.
 

vgta88

Member
Joined
Nov 15, 2007
interesting so there was still power going to the motherboard but the psu is bad... that leaves a bit of a mystery as to what is up with the psu.
 

Bobnova

Senior Member
Joined
May 10, 2009
Mobo requires 3.3v, 5v, and 12v to run. Odds are that just one rail ate it.
 
OP
bohansen

bohansen

Member
Joined
Dec 27, 2004
Probably the case, I have my computer on the majority of the time and its been over 3 years since the build.

Now I gotta decide whether or not to get a refurb PSU for a really cheap price or something new.