• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Config check

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

ihrsetrdr

Señor Senior Member
Joined
May 17, 2005
Location
Close to the San Andreas Fault
I just installed a 8800gt && installed XP on a [email protected]/4gb ram. Running the 182.08 drivers for the 8800gt(stock shaders, ATM). Installed vmplayer and gave the vm 4cores and 1024gb ram. Set vmware-vmx.exe in TM to "low"; The vm linux client is running as I would expect, for a p26xx WU, so no issues there. The GPU client is running a p5771 with a TPF of 6min. 29sec, yielding approx. 1030 PPD. That seems a bit low, so I'm scratching my head and scouring this and the FF to see if I've missed something. My only other GPUs are both running in XP, same drivers-no VM or SMP and currently working a couple P591x WUs with a similiar TPF, except of course, the P591x's are worth far more PPD.

Suggestions? Anyone currently running a p5771 for comparison?
 

torin3

Member
Joined
Dec 25, 2004
This is assuming you have the systray GPU client (I don't know how to do this on the console), but under the advanced tab in the GPU client configure pop-up, do you have Core Priority set to "Slightly higher"?
 
OP
ihrsetrdr

ihrsetrdr

Señor Senior Member
Joined
May 17, 2005
Location
Close to the San Andreas Fault
I'm running the console client, but maybe I can do the same thing in Task Manager...?

Edit: the best organized stats-by-projects I've run across is on fold4life forums. I haven't checked [H] or anywhere else other than foldingforums. Foldingforums may have such, but if so I'm not aware of...
 
Last edited:
OP
ihrsetrdr

ihrsetrdr

Señor Senior Member
Joined
May 17, 2005
Location
Close to the San Andreas Fault
Yes, the client is already at 'low'. Well, I shut down the VM client and closed vmplayer and the GPU TPF immediately dropped to 1 min 20 sec, so it looks like giving the VM all 4 cores isn't going to be feasible. I thought that with nvidia drivers newer than the 177xx series, the GPU client no longer needed core affinity reserved. ?
 

torin3

Member
Joined
Dec 25, 2004
Thats weird, with 2 GTX 295s in an XP system running the same drivers as you are, I was able to get full PPD on the GPUs and run a 4 core VM.

Maybe you should edit the .vmx file for your VM to make sure you have these two lines in it:

priority.grabbed = "normal"
priority.ungrabbed = "idle"
 

AmbientFiction

Senior Folding Zombie
Joined
Jun 16, 2001
Location
Somewhere in the top 100 folders for team 32
Yes, the client is already at 'low'. Well, I shut down the VM client and closed vmplayer and the GPU TPF immediately dropped to 1 min 20 sec, so it looks like giving the VM all 4 cores isn't going to be feasible. I thought that with nvidia drivers newer than the 177xx series, the GPU client no longer needed core affinity reserved. ?

Thats weird, with 2 GTX 295s in an XP system running the same drivers as you are, I was able to get full PPD on the GPUs and run a 4 core VM.

Maybe you should edit the .vmx file for your VM to make sure you have these two lines in it:

priority.grabbed = "normal"
priority.ungrabbed = "idle"


Have you tried adding these environment variables? They helped my folding times. I was able to shave 3 mins per frame on my SMP and I forget how much off my GPU.
Code:
BROOK_YIELD = 2
CAL_NO_FLUSH = 1
CAL_PRE_FLUSH = 1
FLUSH_INTERVAL = 128
MPICH_NO_LOCAL = 1
 

torin3

Member
Joined
Dec 25, 2004
Have you tried adding these environment variables? They helped my folding times. I was able to shave 3 mins per frame on my SMP and I forget how much off my GPU.
Code:
BROOK_YIELD = 2
CAL_NO_FLUSH = 1
CAL_PRE_FLUSH = 1
FLUSH_INTERVAL = 128
MPICH_NO_LOCAL = 1

I've seen these for ATI cards before. Do they work for Nivida cards?
 

ChasR

Senior Member
Joined
Apr 12, 2004
Location
Atlanta
Almost every quad I have is running a 4 core VM with GPUs and none of them have problems with the gpus running slower than they should. In fact the opposite is true, the GPus slow down the VM. Priority is the key. If you have the gpu at low and the VM at idle, the gpu will take whatever cpucycles it needs from the VM. In adv config remove the cpu lock so the gpu will take cycles from all the cpu cores instead of competing for resources on one. Consider it load balancing for the SMP client. Do the rest of Torin's fixes and keep the vm minimized. If mouse and keyboard context is in the VM (grabbed), the VM will run at normal priority and there will be very few cpu resources available for the GPU.
 
OP
ihrsetrdr

ihrsetrdr

Señor Senior Member
Joined
May 17, 2005
Location
Close to the San Andreas Fault
Edit .vmx file
set GPU config priority to "low".
Remove the cpu lock in GPU advanced config
ctrl alt & minimize VMplayer

GPU running the p5771 @ 1min 02sec, and VM client TPF 5min 32sec as it should.

:beer: for all ya'all! :salute::thup:

;)
 

ChasR

Senior Member
Joined
Apr 12, 2004
Location
Atlanta
Anyone reading this thread running Win 7 and nVidia gpus , may find they HAVE to run with the affinity enviromnent variables to spread the gpu across all cores. I've only got one Win 7 quad and I had to disable the cpu lock AND add the variable NV_FAH_CPU_AFFINITY, value 15 to get the gpus to use all cores. I don't know if this is a Win 7 issue or a new driver issue.

Edited to correct spelling. Good catch glussier. I actually do know how to spell affinity and got it right 50% of the time. :)
 
Last edited:

glussier

Member
Joined
Apr 10, 2002
Anyone reading this thread running Win 7 and nVidia gpus , may find they HAVE to run with the affinity enviromnent variables to spread the gpu across all cores. I've only got one Win 7 quad and I had to disable the cpu lock AND add the variable NV_FAH_CPU_AFINITY, value 15 to get the gpus to use all cores. I don't know if this is a Win 7 issue or a new driver issue.

The env. variable is NV_FAH_CPU_AFFINITY