• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Connectivity issues with Vista

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

~(o)-(0)~

Member
Joined
Feb 8, 2005
Location
Qc, Canada
Hi guys,

I have a nice little issue for you if you're up to it.

I have a laptop, Toshiba satellite l300, that I am supposed to be fixing.
It is running windows Vista x64 and the issue is that it cannot go on the web.
I get a IUNternet explorer cannot display this page message with teh little globe with a red X on it.

I connect to my network with it fine, the network icon indicates internet connectivity, I can ping google, yahoo or wtv else. However it won't connect to the site.
I have tried connecting using the IP address as well, I get the same result.
I have set it to a static IP, uninstalled the network cards, reinstalled them, same thing.
I have disabled the windows firewall, and there are no other firewalls present that I can see.
I have scanned using the latest AVG, it didn't find anything, but the definitions weren't the latest as I cannot get on the web.
Automatic updates work fine.
Tried with different browsers as well.
I can browse the web using an ubuntu live CD, but I cannot get minipe to boot up for some reason.

I'm really quite stumped at this point, and I've spent way too much time trying to figure this out, if anybody has any idea I'd be grateful for the input.

Thanks,

nick