• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Corsair CPU Liquid cooler troubleshooting...

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Pepi93

Member
Joined
Jul 12, 2002
I have a H100i RGB Plat cpu cooler and twice in the past week I've turned on the PC to hear a rattle coming from the HS block.

I checked on the corsair site and it says this is an air bubble that gets bounced around and they provide troubleshooting steps to fix the issue.

I've done just that and the issue went away immediately after switching from Extreme to Balanced pump RPM. I also tilted the PC back and forth as suggested and my rad is mounted above my cpu so it's the highest point.

My question is...

Is this a normal thing, the air pocket/bubble rattle or is the pump starting to fail? Asking so I know if I should begin a RMA ticket with Corsair.

Thanks!
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
It happened once. I wouldn't worry about it unless it keeps happening. If it keeps happening, contact Corsair, they'll tell you if you can RMA. Just keep an eye on your warranty (when it expires).
 

BugFreak

Joined
Apr 29, 2010
Location
Central FL
It happens with custom loops for sure. To be honest I didn't realize it could happen with a closed loop. It clearing up after switching pump modes is probably because extreme has enough power to move the bubble while balanced does not. I agree with ED if it keeps happening see about an RMA otherwise don't sweat it.