• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

DDR4 2800mhz Ram speed seems low.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

wade7575

Registered
Joined
Feb 9, 2016
I just built a ASUS X99-A PC with Corsair DDR4 2800mhz Vengeance ram when I look in the Bios it say's it's running at 2133 and in ASUS Suite it say's 2159.2 for DRam Frequency.

I set the bios up to just run optimized default's as I decided not to overclock my i7 5920K as it's plenty fast for anything I want to do,I was just wondering if the new DDR4 does not always run at the speed it's supposed to unless set in the bios to run.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Optimized default is 2133, the base for that platform/cpu. If you want your memory to run at 2800MHz, enable the XMP profile. :)
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I should have known that as my last mobo had that same feature on it and I forgot to run it and it's one of those thing's I don't mess with at all because once it's set it set.

Thanks for the help.

I tried going into my Bios and I forget witch Profile used if it was 1 or 2 but the one I choose to run was the one that let's me run my Ram at 2800mhz.

But here's the problem when I do that it overclock's the CPU to 3.8ghz plus,I thought I could the ram at 2800mhz and not have to overclock the CPU or am I wrong on this.
 
Last edited by a moderator:

Woomack

Benching Team Leader
Joined
Jan 2, 2005
When you enable XMP profile then memory will run at 125MHz bclk. At least it happens in case of DDR4-2800. Because of limited memory ratios it's usually like:
2133, 2400, 2666 = 100 bclk
2800, 3000 = 125 bclk ( 100 also works on many motherboards at 3000 but not at 2800 )
3200 = 100 bclk

So if you don't want to overclock CPU then or change CPU ratio manually to lower or use memory ratio that requires 100 bclk.