• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Degradation in PCIE 3.0x16 slot, PCIEX8 runs fine

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Red_LightRanger

Member
Joined
Jul 10, 2006
Recently completed the skylake build below, however I am getting poor performance when the GPU is installed in the top PCIEX16 3.0 slot.

i5 6600k (not overclocked yet)
16GB (2 x 8GB) DDR4 3000
GA-170x-ud5 motherboard
Galaxy GTX 670


Testing in Battlefield 4 (3440 x 1440 on high settings)
When the card is installed in the first PCIE slot (PCIEX 16) everything starts normally running 60+fps, however after 30 seconds or so it goes to $%*& (like 10fps) and never recovers. If I reinstall the card in the 2nd slot down it runs just fine for hrs (60 fps+)

Originally thought it was the slot, so I RMA'd the first board. 2nd board came in last night and after reinstalling everything I get the same errors. Tried the GPU in a buddy's computer and it ran normally.

Other thoughts:
Temps on CPU never exceed 40C and 70C for GPU.
Tested BIOS on MB (current released) as well as latest Beta
Turned off integrated graphics setting on motherboard
Tried multiple Nvidia drivers
When monitoring in MSI afterburner I noticed the power limit was always 0 (either 1 or 0). When it was in the 2nd slot, it was at 1 all the time.

Any suggestions?
 

custom90gt

Member
Joined
Aug 20, 2003
i was trying to help Red_lightranger figure this out and I'm stumped. We put his 670 in my desktop and it runs great, power limit is always at 1. Put it in his 16x slot and it is always 0 (well it starts at 1 when frame rates are good). Put the card in the 8x slot and everything runs fine. I also noticed that the power% in the 16x slot is always ~40%. Seems like it is trying to save power or something weird.

On a side note, there is no m.2 card in either slot, and none of the other pcie slots are populated.

Really struggling with this one...
 

JrClocker

AKA: JrMiyagi
Joined
Sep 25, 2015
Is the graphics card overclocked?

When this sort of thing happens to me, I get a driver crash, and the GPU frequency stays at 405 MHz on my 980 Ti (versus the 1450+ MHz it boosts to). After this happens, there is nothing I can do to get it to boost up again...so I have to reboot the machine.

I added 20 mV to the card, and haven't had it happen since.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
1. Confirm via GPUz that when this happens you are still running at PCIe3 16x.
2. If you are seeing power limits being hit... confirm in MSI AB that you are actually cresting 100%.
3. Is there an updated BIOS for the GPU?

Something doesn't seem right...
 

custom90gt

Member
Joined
Aug 20, 2003
It's not the stock bios, however it's been running on that bios fine for basically the life of the card without issue. Why would moving to skylake cause issues? Why would running it in an 8x slot on the motherboard alleviate the issues? We will try the stock bios, I just don't know why it only has issues on the skylake build and nothing before, especially because it had a lot more headroom in it without requiring extra voltage.
 
OP
Red_LightRanger

Red_LightRanger

Member
Joined
Jul 10, 2006
Back to stock bios on the 670 also my GTX 970 arrived today which was nice to have something else to test.

GTX670 stock bios PCIE16x:
FPS 17.5
Score 441
Min FPS 10.4
Max FPS 45.4

GTX670 stock bios PCIE8x:
FPS 26.9
Score 677
Min FPS 16.2
Max FPS 57.7

GTX970 PCIE16x:
FPS 40.7
Score 1024
Min FPS 21.4
Max FPS 88.5

GTX970 PCIE8x:
FPS 41
Score 1030
Min FPS 22.9
Max FPS 88.7
 

Silver_Pharaoh

Likes the big ones n00b Member
Joined
Sep 7, 2013
Last time I check Pcie x16 vs x8 meant nothing. No losses.....

If no one can solve this very odd issue I'd just stick it in the x8 slot and call it a day. :)
 

custom90gt

Member
Joined
Aug 20, 2003
The most frustrating thing is the card works everywhere but in his new skylake build. Nothing like buying a new setup and not having it work from the get-go...
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Yeah, that has to be annoying... no idea why it would bork in a 16x slot, but not an 8x on the same board.. makes no sense. That said, I've seen weird things with older gpus and new platforms.....occasionally a bios update on the card fixes it. Since you are on a modded bios, I would flash to the stock one aND see if that does it.
 

custom90gt

Member
Joined
Aug 20, 2003
He did return to the stock bios - same issue.

The bios he was running was just the bios for the "OC" version of the card, only a 85mhz overclock on it.
 

custom90gt

Member
Joined
Aug 20, 2003
The second motherboard should have cleared that up though I would think. Also, the 970 seems to work just fine in the 16x slot.
 

Silver_Pharaoh

Likes the big ones n00b Member
Joined
Sep 7, 2013
The second motherboard should have cleared that up though I would think. Also, the 970 seems to work just fine in the 16x slot.
But the GPU in question works fine in your motherboard right?

I don't get this at all :(
Very strange.....
 

MNMadman

Member
Joined
Dec 13, 2015
I would assume incompatibility between mainboard and GPU (could be an unseen BIOS setting or quirk) before incompatibility between chipset/CPU and GPU. If possible, try a different brand Z170 mainboard.

Or, do it the easy way and leave the GPU in the x8 slot.