• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Device Driver Failures

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Jun 22, 2013
New York
Systemic failures of device handling. Suspect registry error or corrupted system file.

Replaced graphics card, from ATI to Nvidia. Did not uninstall ATI prior to installation of Nvidia. Nvidia drivers did not go in smoothly. ATI drivers were extremely difficult to uninstall.

Was forced to install, uninstall, reinstall multiple times. Was on phone with EVGA tech support. After installing different, standalone PhysX (PhysX-9.13.0725-SystemSoftware.msi), resulted in persistent Blue Screen on startup. Went through the system and the registry with a fine tooth comb, solved the blue screen issue. But now I am left with intermittent device failures.

I believe the problem is in the Registry. Something having to do with the way device drivers are handled. Either a problem in each, individual driver handling; or a systemic corruption of the way the registry handles support of all drivers (a common root cause for all drivers).
Can I track down a single error in the registry which affects all drivers support? Or would reinstalling every device and its associated software correct each device individually?

A full re-installation of Windows is not an option at this time. I must repair the current installation.
I am partially disabled, while recovering from a serious injury. I need my computer operational; and I need my devices to properly use their custom functions, in order to use the PC.

Further details:
- Sometimes, at startup, one or more peripheral devices will not be recognized, or its associated software will not be loaded properly.
- Sometimes, during session, a peripheral device will suddenly cease responding.
- Some devices will work again after unplugging and replugging USB. Sometimes it is necessary to plug into different USB port. Sometimes it is necessary to reboot the computer.
- All peripheral devices are affected randomly. Internal hardware components appear to be be experiencing similar issues.
- Mouse, keyboard, remote controls occasionally experience momentary failure. This can manifest as a failure to register a keystroke, button press, or mouse click, or the mouse taking a second to register that I am moving it. This issue may seem small, but with regards to much of what I do, this can actually be critically important. Sometimes mouse will lag or jump to a different part of the screen. One of the worst cases is when dragging multiple entries, the mouse will behave as though I took my finger off the button for a split second; thereby dropping those files in an incorrect directory. If I don't immediately catch the mistake, this can have serious consequences. I must be able to trust that my hardware is doing what I tell it to do.
- Devices most affected: Steelseries Merc keyboard with zBoard/zEngine software, Logitech mouse and Marble trackball with SetPoint + uberOptions software, MCE remote controls and intelliremote software, Zune, Logitech G930 headset, USB hub, Windows Explorer.
- Currently, Windows Update is instructing me to install: NVIDIA - system - nForce HyperTransport Bridge. However, I believe that this should already be installed.
- Also, Device Manager is displaying multiple entries of most devices in: Human Interface Devices\HID-compliant consumer control device, HID-compliant device, USB Input Device. And Mice and Other Pointing Devices\HID-compliant mouse.
- *Some of this was written one or two months ago, when I was first repairing it, then late in the process when I drafted a new support request. Some is based on the past few days. I apologize for any formatting and tense issues.

-*- As of 9/10/2013, PC was operating mostly ok, but with intermittant failures. I was still trying to get help on other support forums, but without much response.
I could limp along with it in that state for 6-12 months, until I'm ready to build a whole new machine.
However, as of 10/10/2013, I am getting regular failures. It suddenly got much worse, and I don't know what's changed.
Keyboard loses custom mappings after approx. 15min idle.
Other devices act similarly; either losing the custom mappings set in software, or losing all functionality, entirely.

-*- At this point, I have reason to believe the problem may be stemming from a combination of Windows device driver support, and something to do with how the system handles power state changes.
I have it set to go to screensaver after 60min, turn display(s) off at 2 hours, but never go to sleep/hibernation. Although it isn't set to change things after 15-30minutes, I think it may be related to windows checking its instructions at certain intervals.
I use 'BlueScreen View' to see info on my BSOD's, and the vast majority of them point to 'ntkrnlpa.exe'.
Is it a file that's corrupted? Or is it a registry entry which handles driver support, that's corrupted?

The following are some of my notes:
8/27/2013 - installed nvidia graphics card, caused major issues.
9/4/2013 5:25pm
1. for %i in (*.exe) do %i /regserver [etc]
2. reboot
BS reg error
3. repair Windows Installer Service - service cannot be started in Safe Mode.
Type this in a command prompt:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\MSIServer" /VE /T REG_SZ /F /D "Service"
and then
net start msiserver
This will start the Windows Installer Service.
Safe Mode with Network
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer" /VE /T REG_SZ /F /D "Service"
and followed by
net start msiserver
This will start the Windows Installer Service.
4. UnInstall PhysX [PhysX-9.13.0725-SystemSoftware.msi] - WORKED
Reboot Normal
BS reg error
5. fsutil resource setautoreset true C:\
Reboot Normal
BS Page fault in nonpaged area
6. Safe Mode Advanced Boot Menu - Enabled Boot Logging (may already have been enabled) - ntbtlog.txt
BS Reg_Error
Disabled Auto Restart After Crash
BS Reg Error
Reboot Safe Mode with Networking.
8. CCleaner - PhysX missing shared DLL's
9. installed phsysX 9.12.1031
BS Reg error
10. searched C:\ for "ATI". many files with "ATI", but likely unrelated.
11. trying to delete: C:\Program Files\Apps\ATI\ATI.ACE\Core-Static \ atiacmxx.dll, atiamenu.dll
C:\Windows\assembly - delete ATI [unsure about some, did not delete] [files with Public Key Token of "90ba9c70f846762e" (Sort by Public key token to get a easier view) - uninstall.]
search registry for references to files. - did not delete.
Renamed 2 Files. Reboot.
refresh c:\windows\ntbtlog.txt
BS Reg Error.
12. Deleted C:\Program Files\Apps\ATI\ (+ 2 dll files).
Also searched C:\ for "CLI". nothing looks ATI-related.
Deleting ATI Registry Keys. a. HKCU/Software/ATI/ACE b. HKLM/Software/ATI/ACE & software/ATI Technologies
* note - lots of other entries in registry with "ATI", "Catalyst",
BS Reg error
13. Cold Boot [Next Day, 9/5/2013, 2pm] No BSOD.
14. minidump analysis by Joey C. - ntkrnlpa.exe
-See BlueScreen View for BSOD info.
15. at idle ~30-60min. BS bad pool header
called Microsoft Tech Support. lvl 2 tech costs $100. lv.1 is useless.
Want to replace ntkrnlpa.exe
16. Windows Update: graphics drivers WDDM1.1, 1.2 - Programs list now shows driver package 320.78 among others. It should be 320.49. 320.78 isn't even for this product line.
stable for now.
17. Registry Backup
Registry Clean [TuneUp Utilities]
Registry Defrag
CCleaner - found 2 ATI reg entries missed by TuneUp.
seems stable (for a few hrs).
period of black screen before Welcome screen may be longer than usual. 10sec? 20-30sec?
* some other potential driver support issues. may have error in win system files or registry with it handling drivers, etc. may need work. may need to re-install software/hardware to fix.
occasional momentary mouse hang/freeze moving/clicking. trackball stops working during session.
zBoard more likely to not load on boot.
zBoard may load ok at boot, but after a time, it may stop functioning.
18. Re-Install sound card, close pc.
* test VGA onboard port. - FAIL
may have reverted drivers when detecting device changes.
beware setting 'onboard' in BIOS. it wont look for pci-e if vga is unplugged.
problems may have been related to machine seeing it as running tandem ports without special chips. only attempt if no cards installed. or do not attempt. not sure if onboard would function without cards installed.
zBoard failed after working for ~20min.
connect display 2.
connect TV
19. "sfc /scannow" (w/guide). - OK.
20. Driver-related problems.
-at times, zboard keys didnt have effect when used on (VLC, Mumble), when focused using taskbar. worked after clicking app window. or after fiddling in program. but without making any changes.
9/7 3:40am - remotes stopped working during session, many hrs in. restarted intelliremote (after terminating process), unplugged and re-plugged remote IR reciever. did not work.
reboot w/device(s) unplugged, then replug. no effect. tried different IR receiver, no effect. scan for hardware changes, no effect. eHome Infrared Receiver (USBCIR).
* Try: 1. Device Manager. 2. Uninstall the device driver. 3. Unplug the USB cord (if this is an external IR receiver) and reboot. 4. replug, diff port. 5. remove the batteries and place a metal object between the + and - terminals. No change.
plugged IR receiver 2 into diff port in front panel, then unplugged. plugged IR 1 into original usb port on hub, device driver installing...works. Intelliremote(+intelliservice) needed to be re-started.
9/12 - ~18 hrs into session, zboard mod not running. profile light is on; zengine reports: no devices.
reboot. Code 43 on "Unknown Device".
21. enabled Dragon Service (Dragonsvc.exe) in startup. was disabled 8/31/2013, 7:40pm. part of Dragon NaturallySpeaking.
22. Intelliremote
-Remote control(s): registering every keypress twice. Began approximately nine hours into session, 30 minutes into VLC.
--Additional notes omitted. Preparing to reinstall intelliremote.

23.* 9/9/2013
Devices failed to load: Mouse 2, Trackball, Keyboard(zEngine), Remote control, Foot Pedal 1 & 2, (all USB Hub?) + Firefox slamming CPU ~50%.
Also, Intelliservice shouldn't be loading at startup, but it does; and occasionally slams CPU ~50% or more.
HID: USB Input Device - this device cannot start (code 10) [Logitech mouse 2 ?]
USB Controllers: Generic USB Hub - this device cannot start (code 10) [USB Hub ?]
Unknown Device - Windows has stopped this device because it has reported problems Code 43 [Logitech Trackball]
-uninstall every device under the Universal Serial Bus controllers hardware category in Device Manager as part of the driver reinstall. This includes any USB Mass Storage Device, USB Host Controller, and USB Root Hub.
Device Manager - Uninstalled Standard Enhanced PCI to USB Host Controller or Standard OpenHCD USB Host Controller - and it refreshed devices.
then tried to uninstall things again, so i could reboot after (to complete what it said to do.) BSOD, reboot BSOD. Last Know Good Config. OK, but dev manager is now populated with multiple entries.
sys32\drivers - most
sys32 - logilda
-device manager - many multiple entries. devices - details - if no driver, uninstalling. careful. aparently uninstalled my mouse. 2 buttons only. scan for new hardware. re-populated the crowded list. but device works.
-Keyboard, Mouse, remote - occasionally dont respond. missed keystrokes, clicks. even while clicking & dragging it'll act as if i stopped the drag for an instant.
trackball - logitech trackman marble driver.
Maybe re-install Set Point.

24.* 10/18/2013
keyboard failures. re-install? [the software is running. opens ok. keyboard light is on. but custom mapping is off.] and again, shortly after reboot. re-plugged kb, works.
10/14/2013. track ball+ kb fail overnight. + during sessions.
Marble Trackball can't stay connected for more than 10 minutes. if i leave pc for 15min~ idle, the keyboard stops working right. power state-related? ntkrnlpa.exe! (+ device mngr has doubled entries.)
Keyboard, trackball, others - if device is not used for ~15min, it stops working. Unplug+re-plugging usually fixes this, until the next time.
virtually every peripheral, and possibly some internal hardware.
cold boot - most devices not working, or not working properly. it takes a reboot or two to get it to load correctly. failures during sessions.
Is it a file that's corrupted? Or is it a registry entry which handles driver support, that's corrupted? Or every, individual driver/registry entry.
Ask for support.
next, un-inst + re-install software + drivers + devices.
Last resort is full Win7 re-install. - not feasible with current injuries.

-Cross-posted on a few sites, because I received no response.
-Thank you very much for any help you can provide.
What makes you think it's OS related?
Could be hardware failure.
You give no system specs at all.
You need to start from scratch checking all hardware first.