• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

DUAL BOOT!!! minus a mouse....

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

PhoenixMDM

Piano Man
Joined
Aug 21, 2001
Location
Candia, NH
Hehehheheh!!! I'm booting my watercooled sys with WinXP pro, and Mandrake-linux 8.1 gaming! PLUS, i FINALLY found out how to update my kernel without destroying the MBR!! Some of you may remember my flipping out after 8 consecutive tries not working... I am sooooooooooo psyched right now.....


Except one problem: Now that i got mandrake all updated and junk, it dosn't see my M$ USB Optic Wheel mouse. It worked fantastic (actually worked better in linux than windows... go figure!) before updating, and now the only way for me to do half the stuff in GUI is that Alt-F12 trick. I'd like to NOT hook the mouse into the PS2 port, since it works soooo much better in USB, and i have too many USB ports :D

Anyone direct me to a site with a driver or something so it sees the stupid mouse?

*edit: and NO, the control panel-like-thing dosn't work, even when i select USB wheel mouse. And yes, the mouse is still under warantee, no mods yet! *eyes wander to unattached blue LED...*
 

gaccm

Registered
Joined
Aug 29, 2001
when you compiled your new kernel did you include:

USB support
input core support
mouse support (the one under input core)
USB Human Interface Device OR USB Mouse (basic) support
?

You need all of those, to get a usb mouse working 100%
maybe you can install all of the ones you missed as modules, so then you wont have to recompile the kernel.
 

David

Forums Super Moderator
Joined
Feb 20, 2001
Make sure it is not looking for the mouse on /dev/psaux - that is the PS2 port. Look for the device it is using in /etc/X11/XF86Config. I can't remember which device is the USB mouse, but when you find what it is do:

ln -s /dev/<usb mouse device> /dev/mouse

That way you can just set the PC to look for the mouse under /dev/mouse - you can always alter the link if you change your mouse.
 
OP
PhoenixMDM

PhoenixMDM

Piano Man
Joined
Aug 21, 2001
Location
Candia, NH
Cool! I'll try that asap...

ANd i didn't compile myself (don't laugh!), i used MandrakeUpdate.


Works!!! :-D
 
Last edited: